Closed Bug 1703882 Opened 1 year ago Closed 1 year ago

Support opt-in pre-release functionality

Categories

(Conduit :: moz-phab, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: zeid, Assigned: zeid)

References

Details

(Keywords: conduit-triaged)

Attachments

(1 file)

When there are upcoming new features, major front-end changes, or workflow changes, it would be useful to deploy those changes to a subset of users in order to gather early feedback, fix bugs, and catch any unexpected outcomes.

  • For releases that contain significant changes (see above), a pre-release should be published before a regular release
  • Users will have the ability to opt-in to self-updating to pre-releases via a setting in ~/.moz-phab-config
  • Pre-releases should otherwise be treated the same as regular releases
Keywords: conduit-triaged
  • adds get_pre_releases configuration flag
  • appends --pre to pip command if flag is on
Attachment #9221383 - Attachment description: WIP: Bug 1703882 - Support opt-in pre-release functionality → Bug 1703882 - Support opt-in pre-release functionality r=dkl,glob
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Duplicate of this bug: 1698190
You need to log in before you can comment on or make changes to this bug.