Closed Bug 1703889 Opened 8 months ago Closed 8 months ago

Hide disabled page actions in the overflow pageactions menu

Categories

(Firefox :: Toolbars and Customization, task, P2)

task

Tracking

()

RESOLVED FIXED
89 Branch
Tracking Status
firefox89 --- fixed

People

(Reporter: mak, Assigned: rpl)

References

(Blocks 3 open bugs)

Details

(Whiteboard: [proton-address-bar][priority:2a] )

Attachments

(2 files)

Without Proton, disabled pageactions are shown in the menu, but not pinned of course.
With Proton the menu is gone, so normally disabled page actions are not shown, but in windows smaller than 680px they are shown inside the "overflow" meatball menu. That is inconsistent and Luca in https://phabricator.services.mozilla.com/D111271#inline-620165 suggested we should just hide disabled page action extensions in the overflow menu for Proton urlbar.

That requires to modify some tests (likely something in pageactions-proton/) and add a new test to extensions/test/browser/browser_ext_menus.js to check disabled add-ons are not shown in the menu.

I'm setting [priority:2a] because add-ons team requested this to happen asap.

Component: Address Bar → Toolbars and Customization
Assignee: nobody → lgreco
Status: NEW → ASSIGNED

Pushed to try here: https://treeherder.mozilla.org/jobs?repo=try&revision=e3a7eb506e460c005a0f1f4b6a1894ac2fc3e993

I have explicitly tested locally (and fixed if necessary) a bunch of tests that I knew about, and added a new one to explicitly cover the expected behavior, but I wouldn't exclude that there may be some more tests that fails because they still assume that a disabled extension pageAction would be available in the urlbar overflow menu.

(In reply to Luca Greco [:rpl] [:luca] [:lgreco] from comment #2)

Pushed to try here: https://treeherder.mozilla.org/jobs?repo=try&revision=e3a7eb506e460c005a0f1f4b6a1894ac2fc3e993

Well, apparently the only related failure in my push to try is the same one Harry is fixing in Bug 1703838 (which wasn't part yet of the patches I pushed to try), that's good.

And so this is ready for review.

Blocks: 1704139
Blocks: 1704171

In the Proton UI the disabled extension pageActions are not available in both the urlbar
and the urlbar overflow menu, and non or the builtin actions seems to be visible when
disabled in Proton. And so this particular rule isn't needed in Proton and can be moved
into the group of stylesheet rules restricted to the non-Proton UI.

Depends on D111423

Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/f54c679ded81
Ensure hidden extension pageAction are not visible in the urlbar overflow menu on Proton. r=mixedpuppy,mak
https://hg.mozilla.org/integration/autoland/rev/2e13cdc47fb9
Move disabled action fill-opacity rule into non Proton CSS rules. r=mak
Severity: -- → S2
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch
You need to log in before you can comment on or make changes to this bug.