Closed Bug 1703943 Opened 8 months ago Closed 8 months ago

Icon is wrongly displayed on FxA notifications when add-on update banners appear in the Hamburger Menu.

Categories

(Firefox :: Menus, defect)

defect

Tracking

()

VERIFIED FIXED
89 Branch
Tracking Status
firefox87 --- disabled
firefox88 --- disabled
firefox89 --- verified

People

(Reporter: clara.guerrero, Assigned: mhowell)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [proton-hamburger-menu])

Attachments

(5 files)

Attached image Imagen de iOS.jpg

Affected platforms:
Platforms: Ubuntu 20.04

Preconditions:
Reach about:config and set browser.proton.enabled = true
Create 2 fresh profiles

Step to reproduce:

  1. Firefox is opened.
  2. The add-on update banners must be displayed in the Hamburger Menu

To trigger the banners follow these steps:
(An add-on requires new permissions banner)

  1. Install version 1.35.2 of Bitwarden – Free Password manager - https://addons.mozilla.org/en-US/firefox/addon/bitwarden-password-manager/versions/?utm_content=search&utm_medium=referral&utm_source=addons.mozilla.org
    install version 7.0.0 of New Tab Override - https://addons.mozilla.org/en-US/firefox/addon/new-tab-override/versions/?utm_content=recommended_fallback&utm_medium=referral&utm_source=addons.mozilla.org
  2. Wait for the add-on to automatically attempt to update itself. The waiting process can be shortened by changing the value of the extensions.update.interval pref from 86400 to any lower value, for example 60. After changing the value, restart the browser.
  3. Notice that the Hamburger Menu icon displays an orange warning sign.
  4. Open the Hamburger Menu and observe the banner stating that the add-on requires new permissions.
  5. Go to about:addons > themes and switch between the different themes, and compare with dark theme

Expected result:
Icons color should match in every badge, both notifications and the hamburguer menu itself, within every theme chosen.

Actual result:
Icon is wrongly displayed in dark theme. (one looks yellow, the other one orange, seems subtle on my screenshot but it's more notorious on my screen)

Has Regression Range: --- → no
Has STR: --- → yes

I was able to reproduce it on macOs 11 Big Sur.
Also, this behavior happens when the "Update available - Restart now" notification is displayed. I'll add a file.

Assignee: nobody → mhowell
Status: NEW → ASSIGNED
Duplicate of this bug: 1703939
Severity: -- → S3

Bug 1702067 changed the background and icon colors for the app menu banner
notifications to fit the Proton specs, but did not update the app menu button
badges (or the accounts toolbar button badge) to match those colors, so they
currently look mismatched visually. This patch updates the badge colors to use
the same variables as the banners.

Whiteboard: [proton-door-hangers]
Whiteboard: [proton-door-hangers] → [proton-hamburger-menu]
See Also: → 1705515
Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1dddecb08b36
Update app menu button badge colors to match the menu banner icon colors. r=desktop-theme-reviewers,dao
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch
Flags: qe-verify+

This issue is no longer reproducible in 89.0a1 (2021-04-18) (64-bit) nightly build.
Updating flags accordingly.

Best,
Clara

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.