Closed Bug 1704046 Opened 8 months ago Closed 8 months ago

"Not now" "Dismiss" and "Cancel" buttons from the Notification panels dissapear on Hover with High Contrast enabled

Categories

(Firefox :: Menus, defect)

Desktop
Windows 10
defect

Tracking

()

VERIFIED FIXED
89 Branch
Tracking Status
firefox87 --- unaffected
firefox88 --- disabled
firefox89 --- verified

People

(Reporter: rares.doghi, Assigned: mhowell, NeedInfo)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [proton-hamburger-menu])

Attachments

(4 files)

Attached image HighContrastHoudini.png

[Affected platforms]:
Platforms: Windows 10

[Preconditions]:

Reach about:config and set browser.proton.enabled = true
Enable High Contrast Black Windows theme

[Steps to reproduce]:

  1. Launch the Firefox Browser and wait for the Update and Restart notification panel
  2. Hover over the Not now/Dismiss/Cancel buttons from any notification panel

Expected Result:
The Cancel buttons should highlight correctly with High Contrast on

Actual Results:
The Cancel/Dismiss/Not now buttons dissapear from the panel when the user hovers over them with High Contrast Blac theme enabled

Please note that the same issue occurs with High Contrast White theme.

Has Regression Range: --- → no
Has STR: --- → yes
Whiteboard: [proton-door-hangers]
Whiteboard: [proton-door-hangers] → [proton-hamburger-menu]
Assignee: nobody → mhowell
Status: NEW → ASSIGNED
Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/07ab61621784
Prevent popup buttons from disappearing in some Windows high-contrast themes. r=desktop-theme-reviewers,harry
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

This issue is Verified as fixed in our latest Nightly build 89.0a1 (2021-04-19).

Updating the status flag for this issue.

Status: RESOLVED → VERIFIED

Rares, I think this might have regressed. Do you mind verifying it again for 89/beta? I suspect bug 1708690 might be the regressor which looks like it appeared in beta 8.

Flags: needinfo?(rares.doghi)

Hi Mark, I have retested this issue for all 4 panels from Menu Notifications and they all look great no issues with them, I tested this issue in Beta 89.0b10 and Beta 89.0b11.

The only issue I noticed in beta is that on Hover the text from the Cancel button dissapears but not the entire button. I will add a screenshot, I think this issue is fixed in a different bug, I'm not sure though since theres a few issues logged on High contrast and I lost track with what gets fixed where, but if you want I can add a new one.

Flags: needinfo?(rares.doghi) → needinfo?(mstriemer)
Attached image HighContrastText.png
You need to log in before you can comment on or make changes to this bug.