Closed Bug 1704078 Opened 1 month ago Closed 25 days ago

[Proton] When ETP is diasbled there is a striped background

Categories

(Firefox :: Protections UI, defect, P2)

Firefox 89
defect

Tracking

()

VERIFIED FIXED
90 Branch
Tracking Status
firefox89 --- verified
firefox90 --- verified

People

(Reporter: oana.botisan, Assigned: ukohasarah)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [proton-door-hangers] [priority:2b] [proton-uplift])

Attachments

(3 files)

Attached image etp no trackers.png

Affected versions

  • Firefox 89.0a1

Affected platforms

  • Windows 10 x64
  • Ubuntu 18.04 x64
  • macOS 10.15

Precondition
The following prefs are set to true in about:config:

  • browser.proton.enabled
  • browser.proton.doorhangers.enabled (for preliminary testing this also required, until the work is moved to the main pref)

Steps to reproduce

  1. Go to https://www.reddit.com/
  2. Click on the shield icon and turn off ETP.
  3. Click on the shiled icon again and observe panel.

Expected result

  • There is a one colored background.

Actual result

  • There is a striped background.

Regression range

  • This is not a regression.

Additional notes

  • Please look at the attached image. It's the one from the specs.

This is how it looks at the moment.

Has STR: --- → yes
Priority: -- → P2
Whiteboard: [proton-door-hangers] [priority:2b]
Duplicate of this bug: 1704345
Assignee: nobody → ukohasarah
Status: NEW → ASSIGNED
Attachment #9216568 - Attachment description: Bug 1704078 - Remove striped background [Proton] When ETP is disabled r=prathiksha → Bug 1704078 - Remove striped background [Proton] When ETP is disabled r=prathiksha
Attachment #9216568 - Attachment description: Bug 1704078 - Remove striped background [Proton] When ETP is disabled r=prathiksha → Bug 1704078 - Remove striped background [Proton] When ETP is disabled r=prathiksha
Pushed by prathikshaprasadsuman@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/765ce198ebee
Remove striped background [Proton] When ETP is disabled r=prathiksha
Status: ASSIGNED → RESOLVED
Closed: 25 days ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

Verified the fix using Nightly 90.0a1 on Windows 10 x64, Ubuntu 18.04 x64 and macOS 10.15. The issue is not reproducing anymore.

Status: RESOLVED → VERIFIED

Comment on attachment 9216568 [details]
Bug 1704078 - Remove striped background [Proton] When ETP is disabled r=prathiksha

Beta/Release Uplift Approval Request

  • User impact if declined: Required for MR1 / Proton
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is a very contained, well-understood CSS change.
  • String changes made/needed: None.
Attachment #9216568 - Flags: approval-mozilla-beta?
Whiteboard: [proton-door-hangers] [priority:2b] → [proton-door-hangers] [priority:2b] [proton-uplift]

Comment on attachment 9216568 [details]
Bug 1704078 - Remove striped background [Proton] When ETP is disabled r=prathiksha

Approved for 89 Beta 3, thanks.

Attachment #9216568 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified the fix using Firefox 89.0b3 on Windows 10 x64, macOS 10.15 and Ubuntu 18.04 x64. The issue is not reproducing.

You need to log in before you can comment on or make changes to this bug.