Closed Bug 1704106 Opened 1 month ago Closed 1 month ago

Add Timespan's `set_raw` to the Rust trait and the RLB

Categories

(Data Platform and Tools :: Glean: SDK, task, P1)

task

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: chutten, Assigned: chutten)

References

Details

Attachments

(3 files)

We have concrete uses for setting raw values to timespan metrics in FOG. Which means we need to drill set_raw up through the layers.

Blocks: 1704107
Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Pushed by chutten@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3b917d3c21ef
Update Glean SDK to v36.0.1 r=Dexter
https://hg.mozilla.org/integration/autoland/rev/6c557e8ca299
Expose timespan's set_raw API to all FOG languages r=Dexter
Duplicate of this bug: 1704107
You need to log in before you can comment on or make changes to this bug.