Closed Bug 1704310 Opened 8 months ago Closed 7 months ago

Bookmarks toolbar text color is low contrast in Firefox Dark theme

Categories

(Firefox :: Theme, defect, P3)

Firefox 89
Desktop
Windows 10
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr78 --- unaffected
firefox87 --- unaffected
firefox88 --- unaffected
firefox89 --- fixed

People

(Reporter: alice0775, Unassigned)

References

(Regression)

Details

(Keywords: nightly-community, regression, Whiteboard: [proton-toolbar])

Attachments

(2 files)

Attached image screenshot

STR:

  1. Enable Dark theme in about:addons

Actual results:
low contrast than Firefox87.
it looks like placeholder text color or disabled color.

Expected results:
more blight than placeholder text color, at least.

Regression window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=491e7026b24626ce51672da5b886af2904c27be8&tochange=af4bfd54ecd00c1df9ddb9cccd0b4df8f218028c

Keywords: access

The contrast of this text is over 7:1 which is well within accessibility guidelines for supporting users with low vision. This may be a general usability issue if users are confused and think the text is somehow disabled, but it is not an accessibility issue, I don't think.

Keywords: access
Attached image Sans titre.png

Alice, there were several dark mode changes that happened since you files the bug and I cannot reproduce how font look on your screenshot now on Win10, can you please confirm if your contrast issue still applies and otherwise resolve the bug?

Flags: needinfo?(alice0775)
Priority: -- → P3
Whiteboard: [proton-toolbar]

The problem was fixed. thanks.

Status: NEW → RESOLVED
Closed: 7 months ago
Flags: needinfo?(alice0775)
Resolution: --- → FIXED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.