Closed Bug 1704464 Opened 1 year ago Closed 1 year ago

Can't print using the contextual option "Print Frame..."

Categories

(Toolkit :: Printing, defect)

defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox-esr78 --- unaffected
firefox87 --- wontfix
firefox88 --- wontfix
firefox89 --- wontfix
firefox90 --- fixed

People

(Reporter: simona.marcu, Unassigned)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Affected platforms:
macOS Big Sur 11.2
Windows 10 x64

Affected versions:
Nightly 89.0a1

Pre-requisites:
fission.autostart=true
gfx.webrender.all=true

Steps to reproduce:

  1. Launch Firefox.
  2. Access the following:
    https://emilghitta.github.io/TestPages/TestCases/iframeTest/MaineIframeTestPage.html
  3. Right-click on the "Cross origin iframe" -> This Frame -> click on Print Frame...

Expected Result:
The print UI dialog should be properly opened with the content preview and the cross-origin frame should properly be printed.

Actual Results:
The print UI dialog is opened but the content is loading indefinitely and can't be print.

Notes:
Mozregression found commit message:
Bug 1685184 - This Frame > Print Frame... prints top-level page
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=f0767d452fc428b1ec0a7e8c31919106056e60e0&tochange=da5162683ba3148780b0c2114aff952004dd786d

Has Regression Range: --- → yes
Has STR: --- → yes

Emma can you take a look at this?

Flags: needinfo?(emalysz)

Simona, are you still seeing this problem?

I used the STR (am on macOS) and was unable to reproduce

Flags: needinfo?(emalysz) → needinfo?(simona.marcu)

(In reply to Emma Malysz from comment #2)

Simona, are you still seeing this problem?

I used the STR (am on macOS) and was unable to reproduce

I can't reproduce it anymore, tried on both macOS and Windows 10 using the latest Nightly 90.0a1.

Flags: needinfo?(simona.marcu)
Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.