Status

()

Firefox
Toolbars and Customization
VERIFIED WONTFIX
16 years ago
12 years ago

People

(Reporter: Brian Crescimanno, Assigned: David Hyatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Users should have the option of displaying their toolbar / location bar and
"personal toolbar" on the same bar.  There's no reason that users should be
forced to keep them separate.  So instead of:

[buttons][location][spinner]
[link] [link] [link] ...

they could conceivably have:

[buttons][location][spinner][link][link]...
(Reporter)

Comment 1

16 years ago
This should probably apply to the menu (file, edit, etc.) bar as well.

Comment 2

16 years ago
I proposed this a while ago when we were designing the feature. I suggested a
<link containing thing> as a button available in the customizable toolbar
dialog. In a world with multiple configurable toolbar something like that might
have made sense. It doesn't in the design that's been chosen so this will
probably be marked won'tfix. 

It is up to the Module Owner to decide, though. 

Hyatt?
(Reporter)

Comment 3

16 years ago
I understand where you're coming from (sort of, I suppose if I knew more about
the intended design, I would know more).

However, I'm an admin over at Customize.org, and we've been showing off Phoenix
to our users since last night, and the number 1 question that's been asked of us
is "can I move those toolbars around?"

I wouldn't necessarily call it a priority item, but if your goal is to give the
user the best possible experience, that's one option that shouldn't be taken
away from them.

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

16 years ago
so what you're asking for is multiple dockable toolbars. Hyatt has already said
that we're not doing that, at least not any time soon. 
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WONTFIX

Comment 5

16 years ago
while we don't have dockable toolbars you may be pleased to see that tomorrow's
builds will let you move all these items (not the menubar) to the same toolbar
in the customization window.
Status: RESOLVED → VERIFIED

Comment 6

15 years ago
Taking QA Contact
QA Contact: asa → bugzilla

Updated

12 years ago
QA Contact: bugzilla → toolbars
You need to log in before you can comment on or make changes to this bug.