On execute of apprunner.exe get nsNativeComponentLoader failed.

VERIFIED FIXED

Status

()

P3
blocker
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: derek, Assigned: dp)

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Running M10 release on Windows 95 and on execute of apprunner.exe get
nsNativecomponentLoader: SelfRegisterDLL(c:\mozilla\bin\components\xxxxx.dll)
Load FAILED with error: error 0.

This happens for the following dll's raptorhtml, testdynamic, xpacct32, pics,
msgcompo and raptorwidget (this one does not have a path precursoring it).

I am able to run M10 just fine on Windows 98.  I was able to also run on Windows
95 previously.  I reinstalled Windows less than five days ago and redownloaded
M10 and this is when the problem started.

Here is my take.  I work for the government so we are running Win95 revision A.
(Scary Huh!).  I originally had Personal Web Server installed (which probably
updated some dll's) and M10 worked fine.  On reinstall of this ancient version of
Windows 95 I believe I am probably missing a newer dll you depend on.

Any ideas?  or is this theory whacked?  I believe Revision A had weak DCOM
support if any and had serious RPC issues.  Does this ring any bells?
Unfortunately upgrading to Windows 98 is not an option here.

Please let me know.  (derek@forchrist.com)
(Reporter)

Updated

19 years ago
Target Milestone: M10
(Reporter)

Comment 1

19 years ago
I have captured all error messages to a file, please let me know if you would like a
copy.
(Assignee)

Updated

19 years ago
Assignee: dp → leger
(Assignee)

Comment 2

19 years ago
Sounds like it. I will get our testing department to reproduce this.

Jan, any help here.
(Assignee)

Updated

19 years ago
Target Milestone: M10
(Assignee)

Comment 3

19 years ago
Clearing TFV. We will set that once we analyze the bug. Engineer fixing the bug
owns that field.
(Reporter)

Comment 4

19 years ago
I installed the DCOM patch to upgrade to DCOM 1.3 from Microsoft.
(http://www.microsoft.com/com/dcom/dcom95/relnotes.asp)  This did not fix the
problem.  I tried the nightly build from 10/25/99 and the problems still occur,
although the error reporting is much better. : )  Guess that kills my RPC/DCOM
theory.

Updated

19 years ago
Assignee: leger → dp
QA Contact: dp → gbush

Comment 5

19 years ago
gbush, can you reproduce this?

Comment 6

19 years ago
I am unable to reproduce, used Win32 Install Zipfile from the M10 page on
mozilla.org and unzipped into ~seamonkey/bin, doubleclicked on apprunner

this is what displays in console when I run (my comments in ())
Registering DOM Viewer
RegisterSelf([xpconnect wrapped nsIComponentManager],[xpconnect wrapped
nsIFileSpec],rel:nsSample.js,text/javascript)
RegisterSelf done
got a request
runLoadDetectorsMenu()
got a request

(Profile Wizard came up-I entered data and seamonkey launched)
I have Win95 4.00.950 and saw that message for raptorhtml weeks ago on my slow
95 machine.  I have not had problems other than slowness on that machine lately.
(Reporter)

Comment 7

19 years ago
The problem I am experiencing is on v 4.00.950a (OLD).

Here is some additional data that I have gathered.  There is a windows update
(www.microsoft.com/windows95/downloads/) that updates the windows library.  I
tried applying this fix, but it did not seem to update the .dll to the correct versions.

Upon exectution of several other mozilla executables in the root directory I would
get the error:

A required .dll file is missing
Msvcirt.dll

Researching this error led to this article
(http://support.microsoft.com/support/kb/articles/Q187/9/10.ASP) which also calls
for an update of msvcrt.dll.  I finally manually overwrote msvcrt.dll with the newest
version.

This still did not fix the problem.  You would probably have to install a fresh copy
of Revision A to replicate the problem as installing development tools such as
Visual C++ and the likes most likely update the .dlls causing this problem.   Sorry
to be such a pain on such a stupid bug, but working for the government has it
shortcomings.  They insist on waiting for Windows2000 before upgrading the
desktops.
(Reporter)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

19 years ago
Bug Smooshed.

I went around to several PC's here and found one with MSVCIRT.DLL installed.  I
copied to the PC in question.  Voila.  Problem solved.  So Mozilla is dependent on
MSVCIRT.DLL (v5.00.7022) or greater.  This is not default of the Win95a
distribution.

From the looks of my research it looks like if you have SP2 installed for VC++ you
would no longer need this.  You would then be dependent solely on MSVCRT.DLL
in its most current form.  Perphaps this sheds some light elsewhere.  If not, sorry
for the waste of time.  I am just happy I can finally use the best browser out there
now. : )

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 9

19 years ago
Derek,

Thanks for the follow through-

Updated

10 years ago
Component: XPCOM Registry → XPCOM
QA Contact: agracebush → xpcom
You need to log in before you can comment on or make changes to this bug.