Closed Bug 1704717 Opened 5 months ago Closed 5 months ago

[Proton] The words from site permission panel has the first letter of every word in uppercase

Categories

(Firefox :: Site Permissions, defect, P2)

Firefox 89
defect

Tracking

()

VERIFIED FIXED
89 Branch
Tracking Status
firefox89 --- verified

People

(Reporter: oana.botisan, Assigned: emalysz)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [proton-door-hangers] [priority:2a])

Attachments

(2 files)

Attached image permission 1.png

Affected versions

  • Firefox 89.0a1

Affected platforms

  • Windows 10 x64
  • Ubuntu 18.04 x64
  • macOS 10.15

Precondition
The following prefs are set to true in about:config:

  • browser.proton.enabled
  • browser.proton.doorhangers.enabled (for preliminary testing this also required, until the work is moved to the main pref)

Steps to reproduce

  1. Go to https://permission.site/.
  2. Click on the "Location" button.
  3. Click on the "Allow" button.
  4. Click on the site permission icon.

Expected result

  • The text has only the first letter from the first word in uppercase: "Access your location".

Actual result

  • Every word has the first letter in uppercase: "Access Your Location".

Regression range

  • This is not a regression.

Additional notes

  • Please look at the attached image. This is the one from the specs.
Has STR: --- → yes

Seems more like an S4 to me? I'm going to leave prioritization to the Proton folks.

Severity: S3 → S4
Duplicate of this bug: 1704716

This seems related to other issues of similar class that are currently opened.

Priority: -- → P2
Whiteboard: [proton-door-hangers] [priority:2a]

This does not apply to the strings in the cancel button (allow, block, etc)

Assignee: nobody → emalysz
Status: NEW → ASSIGNED
Pushed by emalysz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/97890f6d5035
sentence casing for site permission panel r=flod

Backed out for failures on browser_SitePermissions.js

backout: https://hg.mozilla.org/integration/autoland/rev/529ba4c9c37829e5408311ed2b09604585d11377

push: https://treeherder.mozilla.org/jobs?repo=autoland&selectedTaskRun=UfnV_8p7Tjypg8BxpRKYWg.0&revision=97890f6d5035547f114fb5a85cabd0e8e1ef2b33&searchStr=browser-chrome&group_state=expanded

failure log: https://treeherder.mozilla.org/logviewer?job_id=336686699&repo=autoland&lineNumber=4404

[task 2021-04-15T17:12:49.801Z] 17:12:49 INFO - Buffered messages logged at 17:12:49
[task 2021-04-15T17:12:49.801Z] 17:12:49 INFO - Entering test bound testGetAllPermissionDetailsForBrowser
[task 2021-04-15T17:12:49.801Z] 17:12:49 INFO - Console message: [JavaScript Error: "Error: No DOM node set for aPlacesNode.
[task 2021-04-15T17:12:49.801Z] 17:12:49 INFO - node.type: 0. node.parent: [xpconnect wrapped nsINavHistoryResultNode @ 0x117f9b6a0 (native @ 0x117db5f40)]" {file: "chrome://browser/content/places/browserPlacesViews.js" line: 131}]
[task 2021-04-15T17:12:49.801Z] 17:12:49 INFO - PVB__getDOMNodeForPlacesNode@chrome://browser/content/places/browserPlacesViews.js:131:13
[task 2021-04-15T17:12:49.801Z] 17:12:49 INFO - PVB_nodeTitleChanged@chrome://browser/content/places/browserPlacesViews.js:545:20
[task 2021-04-15T17:12:49.801Z] 17:12:49 INFO -
[task 2021-04-15T17:12:49.801Z] 17:12:49 INFO - Buffered messages finished
[task 2021-04-15T17:12:49.801Z] 17:12:49 INFO - TEST-UNEXPECTED-FAIL | browser/modules/test/browser/browser_SitePermissions.js | {"id":"camera","scope":"{SitePermissions.SCOPE_PERSISTENT}","state":1,"label":"Use the camera"} deepEqual {"id":"camera","label":"Use the Camera","state":1,"scope":"{SitePermissions.SCOPE_PERSISTENT}"} - JS frame :: chrome://mochitests/content/browser/browser/modules/test/browser/browser_SitePermissions.js :: testGetAllPermissionDetailsForBrowser :: line 50
[task 2021-04-15T17:12:49.801Z] 17:12:49 INFO - Stack trace:
[task 2021-04-15T17:12:49.801Z] 17:12:49 INFO - chrome://mochitests/content/browser/browser/modules/test/browser/browser_SitePermissions.js:testGetAllPermissionDetailsForBrowser:50
[task 2021-04-15T17:12:49.801Z] 17:12:49 INFO - TEST-PASS | browser/modules/test/browser/browser_SitePermissions.js | "undefined" == "undefined" -

Flags: needinfo?(emalysz)
Pushed by emalysz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f27f2a126a3a
sentence casing for site permission panel r=flod
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch
Flags: needinfo?(emalysz)
Flags: qe-verify+

Verified the fix using Firefox 89.0b2 on Windows 10 x64, Ubuntu 18.04 x64 and macOS 10.15. The issue is not reproducing anymore.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.