starts up slower in Mac OS X 10.2 (Jaguar) than 10.1

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
16 years ago
16 years ago

People

(Reporter: cattmail, Assigned: saari)

Tracking

Details

(Whiteboard: no response in 3 months)

(Reporter)

Description

16 years ago
I noticed that Navigator starts up slower in Mac OS X 10.2 than 10.1.  I was
really impressed with the speed of the startup on the last 0.5.0 release.  I
hope this can be acheived once again.

Comment 1

16 years ago
Dennis, what build ID are you reporting this bug against? Can you provide any
comparitive data demonstrating slower startup under 10.2 than 10.1?
(Reporter)

Comment 2

16 years ago
Well the build is the official release of 0.5.0 and the build# is 2002090913... the only way I could give comparative data on the speed of startup in comparison with Mac OS X 10.2 and 10.1 is reinstall 10.1 (I'm not about to do that), but to give you an idea of what difference I have seen is that when 0.5.0 was released I still didn't have 10.2 yet (I'm currently in Europe, so I had to wait for my copy), but I noticed a big speed up in startup performance with 0.5.0 release of Navigator on Mac OS X 10.1, which was faster than Internet Explorer 5.2.1 (that's impressive)... it was almost instantaneous, and that is on an old iMac G3 running at 400 MHz with 512 MB of RAM, now my Tibook G4 is more impressive, but I expect that.  After I installed Jaguar (10.2) I noticed the startup performance drop back to pre 0.4.0 (or even 0.4.0) performance!

Trust me I loved seeing Navigator beating IE at startup, that was like a championship win in my opinion and with the effort behind Chimera only proves the point!  I figured I would give a heads up on what I was experiencing and I hope a fix is found because Navigator screams speed all around!

Comment 3

16 years ago
Have you noticed any other applications taking longer to start up?
(Reporter)

Comment 4

16 years ago
Not really, I actually noticed Netscape 7 pickup a little speed boost in startup (though it's still slower than others).  Sherlock is slower, but it's also totally new and different.  Has anyone else noticed apps startup slower than usual?

Comment 5

16 years ago
Dennis, it might be worth trying a recent nightly Chimera build as well.
Dennis, get a recent build with a clean profile and test it under both 10.2.2
and 10.1.5. If the former is still clearly slower, REOPEN this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
Whiteboard: no response in 3 months
You need to log in before you can comment on or make changes to this bug.