Closed Bug 1704817 Opened 2 months ago Closed 1 month ago

App Menu/Library dropdown items don't use theme focus ring color

Categories

(Firefox :: Foxfooding, defect, P2)

Desktop
macOS
defect

Tracking

()

RESOLVED FIXED
90 Branch
Tracking Status
firefox89 --- fixed
firefox90 --- fixed

People

(Reporter: jheavener, Assigned: mconley)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-door-hangers] [priority:2a] [foxfooding][internal] [proton-foxfooding])

Attachments

(1 file)

steps to reproduce/what did you do?

  • First, tab through the chrome to observe the dark/neon blue focus ring color (depending on the theme you have chosen)
  • Now tab into one of the dropdown menus like Application menu or Library

expected behavior/ what did you think will happen?

  • Focus ring color is blue like the rest of the chrome

actual behavior/ what actually happened

  • Focus ring color uses my system accent color (in my case, orange)

additional notes

For me, the issue is not so much that it's one color or the other, it's that it's inconsistent. Especially in dark theme where the orange sticks out.

Martin, my understanding is that accent color supoport was dropped so this seems like a valid macOS issue?
Not captured anywhere else?

Flags: needinfo?(mbalfanz)
Whiteboard: [proton-door-hangers][priority:2c]
Priority: -- → P2
Whiteboard: [proton-door-hangers][priority:2c] → [proton-door-hangers][priority:2a]

Confirmed this is a FE issue, FE has to set a color.

Flags: needinfo?(mbalfanz)
Whiteboard: [proton-door-hangers][priority:2a] → [proton-door-hangers][priority:2a] [foxfooding]
See Also: → 1705447
Whiteboard: [proton-door-hangers][priority:2a] [foxfooding] → [proton-door-hangers] [priority:2a] [foxfooding]
Priority: P2 → P1
Priority: P1 → P2
Whiteboard: [proton-door-hangers] [priority:2a] [foxfooding] → [proton-door-hangers] [priority:2a] [foxfooding][internal] [proton-foxfooding]
Assignee: nobody → mconley

Speaking with Jody, it looks like this has been fixed in Nightly, but Beta is still affected. I'll hunt down what fixed it, and then we can decide if it's worth the uplift.

This was fixed in Firefox 90 by bug 1709350.

Shilpa, the patch in bug 1709350 is pretty low-risk. Shall we request uplift for it to fix this bug for MR1?

Depends on: 1709350
Flags: needinfo?(smohanty)
Status: NEW → ASSIGNED

Yes, let's uplift this one. Thanks, Mike.

Flags: needinfo?(smohanty)

Bug 1709350 was uplifted, which fixes this bug. I think we're done here.

Status: ASSIGNED → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch
You need to log in before you can comment on or make changes to this bug.