Closed Bug 1705272 Opened 9 months ago Closed 9 months ago

Undefined callback method when opening the new Account Setup from the Account Settings tab

Categories

(Thunderbird :: Account Manager, defect, P1)

Thunderbird 89

Tracking

(thunderbird_esr78 unaffected, thunderbird89+ fixed)

RESOLVED FIXED
90 Branch
Tracking Status
thunderbird_esr78 --- unaffected
thunderbird89 + fixed

People

(Reporter: spowd, Assigned: aleca)

References

(Regression)

Details

(Keywords: regression)

Attachments

(3 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0

Steps to reproduce:

tried setting up a @gmail.com account with the error

Actual results:

once i filled out the gmail account stuff an when Pressed " Done " i got the error listed in the screenshot

Expected results:

i should have been able to proceed setting up the email account after i pressed " Done "

the latest, New Profile with a clean install also

That's Wednesday's daily. (With "Tuesday's" checkins)

Assignee: nobody → alessandro
Severity: -- → S1
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Priority: -- → P1
Regressed by: 1697575

I'm not able to reproduce this error as I was able to correctly setup my gmail account multiple times on a fresh daily installation.
Magnus, can you reproduce this?

Flags: needinfo?(mkmelin+mozilla)

Hi Greg, are you able to reproduce this error with the current daily? 89.0a1 (2021-04-15) (64-bit)

Flags: needinfo?(spowd)

(In reply to Alessandro Castellani [:aleca] from comment #4)

Hi Greg, are you able to reproduce this error with the current daily? 89.0a1 (2021-04-15) (64-bit)

yes i can still reproduce it with the updated Daily from this morning. i could try a newer Profile ?

Flags: needinfo?(spowd)

(In reply to Greg ( Hank1 ) from comment #5)

(In reply to Alessandro Castellani [:aleca] from comment #4)

Hi Greg, are you able to reproduce this error with the current daily? 89.0a1 (2021-04-15) (64-bit)

yes i can still reproduce it with the updated Daily from this morning. i could try a newer Profile ?

ok i just tried a New Profile, still the same problem

i'll test it in the Beta an see if that works . works Fine in Beta, just not Daily

i reckon i had a similar problem to this sometime ago an i think others had the same issue to an it was fixed, i just dont remember what TB version it happened in.

i made a complete new install of TB 89 Daily then , i could setup my personal account fine, but then once i tried setting up my gmail account i couldn't go further when it asked me to Press the " Done " button, it spat that error out again, why would it work fine in 88b3 but not in daily?

Beta still has the old account setup in a dialog.
On daily we shipped the new account setup that opens in a tab in preparation for more updates.
The gmail configuration process was tested before landing this update, so it's weird that is failing for you.
I'm investigating the issue to hopefully find the reason.
Thanks for the info.

I can't reproduce this either on current Daily in Windows 10. Full gmail setup went fine as expected. Both with a new profile and with an old one that had another account in it as well.

well if no one else can reproduce it, i'll have to say Bye bye to Thunderbird an use Microsoft Mail instead :(

(In reply to Greg ( Hank1 ) from comment #11)

well if no one else can reproduce it, i'll have to say Bye bye to Thunderbird an use Microsoft Mail instead :(

when i first installedf 89 with the new account manager, worked without a problem, now this :( so there must be a regression somewhere in your code

ok i just setup a outlook.com address , i get no problem

(In reply to Greg ( Hank1 ) from comment #11)

well if no one else can reproduce it, i'll have to say Bye bye to Thunderbird an use Microsoft Mail instead :(

Nobody is saying that the bug doesn't exist, reproducing it is just a prerequisite for making sure it's fixed.

I'm not sure why you'd need to switch mail clients if the bug is in Daily, just use Beta for now?

(In reply to Andrei Hajdukewycz [:sancus] from comment #14)

(In reply to Greg ( Hank1 ) from comment #11)

well if no one else can reproduce it, i'll have to say Bye bye to Thunderbird an use Microsoft Mail instead :(

Nobody is saying that the bug doesn't exist, reproducing it is just a prerequisite for making sure it's fixed.

I'm not sure why you'd need to switch mail clients if the bug is in Daily, just use Beta for now?

i might do that, still has me stumped on why it only happens with gmail though an not outlook, iv'e even gone into the google settings to make sure everything is enabled to be able to use gmail in TB

Yeah, reproducing the error consistently is the main requirement of fixing a bug, that's why we're trying to make it happen on our end :D

Here are a bunch of questions to try to gather more information:

  • Are you on Windows 10?
  • Do you have a firewall or antivirus that has some specific settings for outgoing google connections?
  • Do you have any add-ons on Thunderbird?
  • Does the problem appear also in troubleshoot mode (former safe mode)?

Do you have another computer to test this? Maybe an old laptop or something like that?
This is to exclude the possibility of your computer having something blocking the google OAuth.

The fact that you get "Can't access property "notificationCallback"..." error worries me because that's a JavaScript error that it shouldn't happen and most importantly it shouldn't be printed in the warning. That error, if it happens, should only be visible in the console, not being user facing.
Also the fact that it happens immediately when you click "Done", it means there might be something very sketchy going on with the code, because normally a popup window for the Google login should open at that stage.

Anyway, we're investigating and we want to find the problem here, so thank you for all the help you can give us and all the detailed information you can provide.

go an have a look at my User Agent Alessandra, ofcourse im on Windows10.

i use Microsoft firewall, i use Microsoft Antivirus, why would it work in 88b3 if they were the cause?
no i dont have any addons in Thunderbird
i havent tried troubleshoot mode, i will try now. ok i just tried troubleshoot mode, still no go

btw, im using 64bit of TB Daily if that makes any difference

I can successfully set up a gmail account on trunk.

Likely unrelated to this bug, for an invalid cert I get

console.error: mail.setup: 
  cert error
JavaScript error: chrome://messenger/content/accountcreation/verifyConfig.js, line 404: NS_ERROR_ILLEGAL_VALUE:

For gmail, I did get this in the console:

JavaScript error: resource:///modules/OAuth2.jsm, line 162: NS_ERROR_NOT_IMPLEMENTED: Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIRequest.name] 

so https://searchfox.org/comm-central/rev/46dad6bb00f19dfc3908a0d9a47673c36cc5d32c/mailnews/base/src/OAuth2.jsm#162

Flags: needinfo?(mkmelin+mozilla)

Is there any set place to find out how to set up a gmail or yahoo account? This seems to be a moving target, and it would make both customer's and support's lives easier if there were. Thank you. Having that might go a long way to solving this bug report.

See Also: → 1705756
Duplicate of this bug: 1705756
See Also: 1705756
Summary: cannot setup a gmail account in latest nightly → LoadPostAccountWizard is undefined when opening the new Account Setup from the Account Settings actions

I was finally able to reproduce it consistently.
The issue only happens if the Account Setup is opened from the Account Settings > Account Actions menu list.
I'll fix it right away!

Status: NEW → ASSIGNED
Attachment #9216475 - Attachment description: Bug 1705272 - Include missing JS file for startup loading in the Account Settings. r=mkmelin → Bug 1705272 - Fix missing callback method when opening Account Setup from the Account Settings tab. r=mkmelin
Summary: LoadPostAccountWizard is undefined when opening the new Account Setup from the Account Settings actions → Undefined callback method when opening the new Account Setup from the Account Settings tab
Attachment #9216475 - Attachment description: Bug 1705272 - Fix missing callback method when opening Account Setup from the Account Settings tab. r=mkmelin → Bug 1705272 - Remove embedded callbacks and use postMessage for the Account Setup. r=mkmelin
Target Milestone: --- → 90 Branch

There's some bitrot, so leaving it for now.

Unbitrotted.

Pushed by thunderbird@calypsoblue.org:
https://hg.mozilla.org/comm-central/rev/b3e9a474def5
Remove embedded callbacks and use postMessage for the Account Setup. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED

Comment on attachment 9216475 [details]
Bug 1705272 - Remove embedded callbacks and use postMessage for the Account Setup. r=mkmelin

[Approval Request Comment]
Regression caused by (bug #): bug 1697575
User impact if declined: Inability to add a new email account if the account setup is opened from the account settings page.
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9216475 - Flags: approval-comm-beta?

Comment on attachment 9216475 [details]
Bug 1705272 - Remove embedded callbacks and use postMessage for the Account Setup. r=mkmelin

[Triage Comment]
Approved for beta

Attachment #9216475 - Flags: approval-comm-beta? → approval-comm-beta+
Duplicate of this bug: 1706926
You need to log in before you can comment on or make changes to this bug.