When going to the URL, html is parially rendered.

RESOLVED WORKSFORME

Status

()

Core
HTML: Parser
--
minor
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Igor Belayev, Assigned: harishd)

Tracking

({testcase})

Trunk
x86
Linux
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2a) Gecko/20020910

After visiting this page:
http://bioethics.net/bioethics_intro.php?task=view&articleID=92

In right panel; bellow Introduction to Bioethics
there should be some text rendered. But there is nothing appearing.
Konqueror and IE render page ok.

The same problem persists on Mozilla 1.1 on windows XP.

Is it just a bad code on server ?
If so, how come other browsers show the page ok ?

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
worksforme as far as I can tell with linux build 2002-09-21-04 (identical
rendering to NS4).  Could you post a screenshot of what you see?
(Reporter)

Comment 2

15 years ago
Created attachment 100430 [details]
A screen of what I see.

The bottom right panel is blank.
There should be some text there.

Could it be a missing font problem ?
Unlikely... are there any errors in the JS console?

Comment 4

15 years ago
Created attachment 100449 [details]
Screenshot, 2002-09-21-04 Linux

Looks like a bad comment somewhere on the page. Odd that this did not occur for

you Boris, with the same build.

Comment 5

15 years ago
Created attachment 100450 [details]
Testcase

This looks like a regression in parsing of SGML markup declaration w. comments?

I don't recall stuff like this being visible before, even in Standards mode.

Comment 6

15 years ago
--> Parser
Assignee: asa → harishd
Component: Browser-General → Parser
Keywords: testcase
QA Contact: asa → moied
Oh, I see the comment thing.  This looks like the "completely unterminated
comment in strict mode gets not parsed as a comment" thing which we do on
purpose, iirc.  Did we also do that in 1.2a?
This is on purpose - a malformed comment in strict mode is not a comment, but
becomes a text node. There is a bug that we eat the opening "<!", see bug 144902.

Comment 9

15 years ago
OK, I just saw that is was different from what we did earlier,
(see bug 102127 comment 16)
Seems like a good change though because I can see directly what the problem is
and the whole page doesn't disappear.
(Reporter)

Comment 10

15 years ago
It's weird.

When I open a new window and go the url, it does not show the
portion of the page. Now, but when I refresh the page. It shows the complete
html page. I can reproduce it with both tabs and new windows.

No errors in java script console.
Another weird thing.
When I have java script console up. The page never gets rendered. Even after I
refresh. After I close java script console, and open a new tab and ask for the
link. It does not get rendered, but now after refreshing the page gets rendered
completely.

Weird.

Anybody else sees the same ?
I was able to reproduce the missing content problem as shown in
attachment 100430 [details] with 2002-09-23-08 trunk Linux.

Igor is right, there is something weird here - I get different results when I
click Reload, Shift-Reload and Stop in different combinations.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 12

14 years ago
Webpage is too old.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
The site has been redesigned so the problem is not reproducible anymore, that
does not say anything about wether the bug in Mozilla has been FIXED though.
Status: RESOLVED → REOPENED
Keywords: testcase
Resolution: FIXED → ---
If anyone can reproduce the Reload/Shift-Reload problem described in comment 11
please file a new bug report, thanks.

-> WORKSFORME
Status: REOPENED → RESOLVED
Last Resolved: 14 years ago14 years ago
Keywords: testcase
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.