Closed Bug 1705597 Opened 9 months ago Closed 9 months ago

[wpt-sync] Sync PR 28531 - Disable compositing for SVG elements with clip-path or mask

Categories

(Core :: SVG, task, P4)

task

Tracking

()

RESOLVED FIXED
90 Branch
Tracking Status
firefox90 --- fixed

People

(Reporter: mozilla.org, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 28531 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/28531
Details from upstream follow.

b'Xianzhu Wang <wangxianzhu@chromium.org>' wrote:

Disable compositing for SVG elements with clip-path or mask

We are still unclear about the root cause of the hairlines around the
bounding box of clip-path or mask. Expanding the mask layer caused
other regressions.

Now disable compositing until we address the root cause.

The test cases are copied from crrev.com/c/2786129 and
crrev.com/c/2787695 both of which have been reverted.

Bug: 1199515
Change-Id: I9ccda705f160a2e9b8c0aa3d9c9c54e0f23c12c2
Reviewed-on: https://chromium-review.googlesource.com/2828782
WPT-Export-Revision: 72f45097430d6e9553e6d13edb17d678f2c89b00

Component: web-platform-tests → SVG
Product: Testing → Core

CI Results

Ran 15 Firefox configurations based on mozilla-central, and Firefox, Chrome, and Safari on GitHub CI

Total 3 tests

Status Summary

Firefox

PASS: 3

Chrome

PASS: 2
FAIL: 1

Safari

PASS: 3

Links

Gecko CI (Treeherder)
GitHub PR Head
GitHub PR Base

Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2716efda21d9
[wpt PR 28531] - Disable compositing for SVG elements with clip-path or mask, a=testonly
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch
You need to log in before you can comment on or make changes to this bug.