[Dogfood] Data Loss: Sending jpeg/gif attachment becomes corrupted

VERIFIED DUPLICATE of bug 10232

Status

defect
P3
major
VERIFIED DUPLICATE of bug 10232
20 years ago
11 years ago

People

(Reporter: pmock, Assigned: rhp)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

Attachments

(2 attachments)

Build Date & Platform Bug Found:
 Win32 seamonkey commercial build 1999-10-21-09-m11 installed on P166 Win98
 MacOS seamonkey commercial build 1999-10-21-08-m11 installed on G3/400 OS 8.5.1
 Linux seamonkey commercial build 1999-10-21-08-m11 installed on P200 RedHat 6.1

Overview Description:
 When I send a jpeg/gif attachment from seamonkey and view it in Communicator
4.7, the attachment is corrupted or displays as a broken link.

I was running my tests under IMAP.  I will attach a sample file.

Steps to Reproduce:
0) Deleted my mozregistry and previous user profile
1) In a dos prompt, run mozilla -mail
   The new profile wizard should appear
2) Enter a profile name and press the finish button
   Messenger should open and the mail/new set up wizard should appear
3) Go through the wizard and configure for imap mail
4) Log into IMAP mail
5) Start a new message
6) Address it to yourself or test account
7) type in a short subject title
8) enter in a short bit of text
9) Click on the attach button on the toolbar
10) Select the attachment
11 [details]) Click on the send button
12) From communicator 4.x, retrieve the message and view it
    The attachment is corrupted.

Actual Results:
 The message is partially displayed or displays as a broken link.  If I save the
image and view it in the communicator browser, it displays the same sort of
corruption.

Expected Results:
 It should send the jpeg/gif file intact without data corruption.

Additional Builds and Platforms Tested On:
 This problem also occurs on today Win32 commercial build 1999-10-22-09-m11

Additional Information:
 When I view a seamonkey message sent from Mac on my Sun Ultra 1 (solaris 2.6)
running Communicator 4.7 RTM, it crashes the application.
Posted image Jpeg attachment
Posted image gif test sample
QA Contact: lchiang → pmock
Summary: Data Loss: Sending jpeg/gif attachment becomes corrupted → Data Loss: Sending jpeg/gif attachment becomes corrupted
changing qa assigned to myself
Summary: Data Loss: Sending jpeg/gif attachment becomes corrupted → [Dogfood] Data Loss: Sending jpeg/gif attachment becomes corrupted
I should also mention that if I view a mesasge that contains an attachment sent
from 5.0 and viewed 5.0, the jpeg/gif is corrupted; it displaying a partial
image or it displays a link.

I nominate this for dogfood consideration.
Assignee: mscott → rhp
I think rhp is a better owner for this
Whiteboard: [PDT+]
Yikes!  Approved for PDT+
Related bug 10232
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
There is a problem with the UUEncoded data being generated for image parts.
Don't ask me what happend, but I'll try to nail this down today.

- rhp


*** This bug has been marked as a duplicate of 10232 ***
Status: RESOLVED → VERIFIED
Verified as duplicate of bug 10232
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.