Closed Bug 1705704 Opened 5 months ago Closed 5 months ago

"Add-ons and themes" in app menu is truncated in French

Categories

(Firefox :: Menus, defect, P2)

defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox89 --- verified
firefox90 --- verified

People

(Reporter: tchevalier, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-hamburger-menu] [priority:2a])

Attachments

(2 files)

Attached image macOS

The current French translation of "Add-ons and themes" in the app menu is "Modules complémentaires et thèmes". It’s currently truncated across all platforms.

The options I see are:

  • Widen the menu a little bit
  • Use "Extensions et thèmes" ("Extensions and themes")
  • Use "Modules et thèmes" (shortened version of current translation, but it’s less ideal)
Attached image Ubuntu

CCing Meridel and Tyler (I think he's the PM working on the app menu?)

Italian has similar problems, but the string is fully displayed on macOS, and cut on Windows because of the length of the keyboard shortcuts (see bug 1703246). Not sure if we want these bugs to be merged into one.

a) Should we try to fix it at UI level, making sure the longest string actually fits? I thought that was we were doing, but it's not. Or maybe it doesn't account for the keyboard shortcuts.

b) How do we feel about locales using "Extensions and themes" as translation, if it's shorter?

See Also: → 1703246

@Amy
Meridel suggested to involve you for a UX perspective.

The way I see it, we have 3 alternative approaches to solve this specific truncation:

  1. Solve it at UX level. For example: change the app menu to actually fit the longest translation, accounting for keyboard shortcuts. Or allow the text to wrap at least on two lines.
  2. Solve it at "content" level, allowing translations to use a different label, i.e. "Extensions and themes". This could solve the specific case, not truncations in general, and even not necessarily for all languages.
  3. Ask translations to shorten their text. That's less than ideal, because it kind of treats other languages as a second-class citizen, and shortened versions might not be as easy to read for users.

For 2, copying from a conversation with Meridel to keep everything in one place.

In English, we felt that we needed to retain the word add-ons as a bridge to current nomenclature elsewhere in product — and that existing users are used to the term add-ons and would be confused if we removed it.

I personally feel that this applies less strongly to other languages: English users are familiar with add-ons because that's what shows up in URLs like addons.mozilla.org or about:addons. International users are somehow exposed to both the term add-on and its localized version (e.g. componenti aggiuntivi in Italian). But if, for example, you select Tools -> Add-ons in release, this brings you to a page where add-on appears only a couple of time (search field, support link), and it's less prominent than the titles in the sidebar (Extensions, Themes). So, are they really that familiar with the localized equivalent of add-on? Unfortunately, that's a feeling without data to back it up.

Even if, I would also not be advocating for "all locales should use Extensions and themes", more like creating space for a different approach if there are truncation issues, like it happens for French and Italian. This still leads to potential confusion, when comparing English and localized product.

Flags: needinfo?(amlee)

@francesco @meridel - Do we know what the worse case scenario for string length is?

I would approach it this way:

  1. Approach it from a content level first in Option 2- If we can shorten the string without compromising on comprehension we do that.

  2. Secondly, we fallback on Option 1 (have text wrap to 2 lines max with truncation afterwards).

Flags: needinfo?(amlee)
Flags: needinfo?(francesco.lodolo)

From a quick look, French followed by Italian (for smaller locales, Occitan and Kaqchikel)
https://transvision.flod.org/string/?entity=browser/browser/appmenu.ftl:appmenuitem-addons-and-themes.label&repo=gecko_strings

The challenge is that it changes based on the OS. Italian works fine on macOS, is cut on Windows because of the keyboard shortcuts (shift and ctrl).

Flags: needinfo?(francesco.lodolo)

@Meridel
How do you feel about some locales using "Extensions and themes", given comment 4?

Flags: needinfo?(mwalkington)
Whiteboard: [proton-hamburger-menu]
Severity: -- → S2

Spoke with Flod and got sign-off from Mikal: In non-EN locales where we are experiencing truncation issues, the menu label can be: Extensions and themes

Flags: needinfo?(mwalkington)

Thanks Meridel.

@Théo
Can you try updating your translation to "Extensions and themes", to verify if that solves truncation issues?

Flags: needinfo?(theo)

(In reply to Francesco Lodolo [:flod] from comment #8)

Thanks Meridel.

@Théo
Can you try updating your translation to "Extensions and themes", to verify if that solves truncation issues?

Updated, will check the next build (keeping NI). It’s very likely to fit on all platforms now

Priority: -- → P2
Whiteboard: [proton-hamburger-menu] → [proton-hamburger-menu] [priority:2a]

It sounds like we've arrived at a solution. I agree with the direction proposed here from the UX team. Please let me know if there's any way I can assist.

Flags: needinfo?(theo)

Confirming the issue is fixed in French

Thanks. Marking this one as fixed, hopefully I'll be able to close the other one (for Italian) over the weekend.

Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED

Hey flod, is there anything for this that needs to be uplifted for 89?

Flags: needinfo?(francesco.lodolo)

Same here, it gets picked up automatically by automation, no concept of uplift for l10n.

Flags: needinfo?(francesco.lodolo)

I confirm that on Fx 88 appears "Modules complémentaires et thèmes".
Verified- Fixed on the latest Fx 89 and Nightly 90(french build), is displayed "Extensions and themes".

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.