Closed Bug 1705743 Opened 1 year ago Closed 1 year ago

Make frequently reported bugs more obvious for enter bug form and duplicates.cgi more intuitive

Categories

(bugzilla.mozilla.org :: General, task)

Tracking

()

RESOLVED FIXED

People

(Reporter: tracy, Assigned: dkl)

Details

Attachments

(3 files)

In an effort to help reduce duplicates filed during the Fx89 beta cycle, we'd like to add a brief reminder to recommend users search bugzilla for the issue before filing a new bug.

Implement this at the beginning of Fx89beta starting April 19th and leave it up for the duration of the beta cycle, as long as it seems to be helping. No real way to measure. If, with the message, dupes are still filed at the 'usual' pace, we can pull the banner down.

first draft of message:

"Please attempt to determine whether the issue you're here to report is a duplicate of a bug already on file. Use this form to search the database. If you find your issue has already been reported, please don't file another bug. Instead, in the Details section of the bug report, Vote for the bug. Thank you for your help."

Depending on a users group permissions they see a different enter bug page. For users in the canconfirm group or higher they see the standard enter bug page with the following text at the top:

[screenshot1]

Consider using the Bugzilla Helper instead of this form. Before reporting a bug, make sure you've read our bug writing guidelines and double checked that your bug hasn't already been reported. Consult our list of most frequently reported bugs and search through descriptions of previously reported bugs.

It has a link to the duplicates.cgi page which shows most duplicate bugs for a given product. This page is very old and needs some work to be more useful.

The guided bug page is displayed to users who are new to Bugzilla and do not have canconfirm permissions. It has a duplicate search form built in that lets users first search for their issue before filing a new report.

[screenshot2]

All employees and a lot of contributors will already have canconfirm permissions and will see the normal bug entry page. I am going to update the duplicate text that is there currently to be separate from the other text and be more prominent. I am going to also do some tweaks to the current duplicates.cgi page to make it more useful. This will include passing along the product name by default and allow also pick a version to search for duplicates. Currently the form shows most duplicated bugs for a product across all versions and this gives some really old bugs at the top which are of no use to the current releases.

Assignee: nobody → dkl
Status: NEW → ASSIGNED
Attached image screenshot1
Attached image screenshot2

David, this sounds great. Thank you.

Summary: Place temporary notification about filing dupes on the enter bug pages → Make frequently reported bugs more obvious for enter bug form and duplicates.cgi more intuitive
Attached file GitHub Pull Request

Merged to master.

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.