Closed Bug 1706025 Opened 5 months ago Closed 5 months ago

[Proton] The warning icon from download panel lacks a fill colour (isn't yellow anymore)

Categories

(Firefox :: Downloads Panel, defect, P2)

Firefox 89
defect

Tracking

()

VERIFIED FIXED
90 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox87 --- unaffected
firefox88 --- unaffected
firefox89 --- verified
firefox90 --- verified

People

(Reporter: ciprian_georgiu, Assigned: Gijs)

References

(Blocks 3 open bugs, Regression)

Details

(Keywords: regression, Whiteboard: [proton-icons] [priority:2a] [proton-uplift])

Attachments

(2 files)

Attached image warning icon.png

Affected versions

  • latest Nightly 89.0a1

Affected platforms

  • Windows 10 x64
  • Ubuntu 18.04 x64
  • macOS 10.15

Steps to reproduce

  1. Launch Firefox.
  2. Go to http://testsafebrowsing.appspot.com/s/pua.exe and download the file.
  3. Click on the download icon from toolbar.

Expected result

  • The warning sign has a yellow color.

Actual result

  • The warning sign has a black color.

Suggested Severity

  • S2, since this is a regression.

Regression range

Additional notes

  • please see the attached screenshot.
Has Regression Range: --- → yes
Has STR: --- → yes
Blocks: proton-icons
Whiteboard: [proton-icons]
Priority: -- → P2
Whiteboard: [proton-icons] → [proton-icons] [priority:2a]
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Summary: [Proton] The warning icon from download panel is not accordingly displayed → [Proton] The warning icon from download panel lacks a fill colour (isn't yellow anymore)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/600cb0eb3e18
add missing fill for warning icon in downloads, r=sfoster
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch
Whiteboard: [proton-icons] [priority:2a] → [proton-icons] [priority:2a] [proton-uplift]

Comment on attachment 9217810 [details]
Bug 1706025 - add missing fill for warning icon in downloads, r?mconley,sfoster

Beta/Release Uplift Approval Request

  • User impact if declined: Required for MR1 / Proton”
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: See comment #0
  • List of other uplifts needed: n/a
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): CSS-only change to adjust some fill colours
  • String changes made/needed: Nope
Attachment #9217810 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

The issue is verified as fixed on latest Nightly 90.0a1 under macOS 10.15, Ubuntu 18.04 x64 and Win 10 x64. Leaving the qe+ flag in place for now, until we verify it on Beta as well.

Status: RESOLVED → VERIFIED

Comment on attachment 9217810 [details]
Bug 1706025 - add missing fill for warning icon in downloads, r?mconley,sfoster

Approved for 89 beta 5, thanks.

Attachment #9217810 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

This is also verified as fixed on latest Beta 89.0b5, under macOS 10.15, Win 10 x64 and Ubuntu 18.04 x64.

Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.