Closed Bug 1706077 Opened 8 months ago Closed 8 months ago

'opsz' value applied by font-optical-sizing should respect any size-adjust in effect

Categories

(Core :: Layout: Text and Fonts, defect, P3)

defect

Tracking

()

RESOLVED FIXED
90 Branch
Tracking Status
firefox90 --- fixed

People

(Reporter: jfkthame, Assigned: jfkthame)

References

Details

Attachments

(1 file)

As agreed in https://github.com/w3c/csswg-drafts/issues/6190, optical sizing should take account of the size-adjust descriptor (if present).

Our implementation doesn't currently do this: it applies an 'opsz' value based solely on the computed font-size, without regard to any size-adjust on the specific face being used.

To fix this, we'll need to push the computation of the 'opsz' value down into the gfxFont code, rather than computing the variation value in nsFont and including it in the variations array, because at that level we're not dealing with a specific concrete font face and so we don't know what size-adjust may be required.

Pushed by jkew@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f6589db7849e
Move setting of 'opsz' axis from nsFont into gfxFont initialization as it depends on data from both the style and the specific gfxFontEntry. r=layout-reviewers,emilio
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch
Regressions: 1714754
You need to log in before you can comment on or make changes to this bug.