Status

()

Core
Layout
--
major
RESOLVED FIXED
16 years ago
16 years ago

People

(Reporter: Gérard Talbot, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
A child node with overflow:auto should take 100% of available remaining width of
its parent node.

This is no longer the case with 2002092408 using XP Pro SP1.

A test case is coming.
(Reporter)

Comment 1

16 years ago
I forgot to mention to go to the given url, try any of the 3 demos and you'll
see in the content (bottom) div an extra unused area at the right side which I
suspect correspond to the width of a vertical scrollbar.
(Reporter)

Comment 2

16 years ago
Created attachment 100498 [details]
Self auto-explanatory reduced test case

There is an unused area at the right hand side of the content area div in this
demo.
I'm quite confused. I don't see what the bug is here. Which DIV is the "content
area div"?
Oh, I was using an old build. Now I see the bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 5

16 years ago
Could it be possible to insert the keyword "regression" into this bugfile? In a
sense, Robert O'C. and I confirm that this is a regression.

I'm quite sure this regression is recent since I downloaded many nightly builds
in the last 20 days and I just noticed this layout problem today.
The regresssion was caused by my checkin for bug 169610.
I think we should backout the change until I can figure out a better fix.

Comment 9

16 years ago
Comment on attachment 100538 [details] [diff] [review]
backout the change

r=karnaze
Attachment #100538 - Flags: review+

Comment 10

16 years ago
Comment on attachment 100538 [details] [diff] [review]
backout the change

sr=kin@netscape.com
Attachment #100538 - Flags: superreview+
Backed out.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.