Closed Bug 1706457 Opened 9 months ago Closed 9 months ago

Redesign the Mac Firefox logo in accordance with Apple's Human Guidelines

Categories

(Firefox :: Untriaged, enhancement)

Firefox 90
enhancement

Tracking

()

RESOLVED DUPLICATE of bug 1648386

People

(Reporter: lisamiller9891, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/89.0.4371.0 Safari/537.36

Steps to reproduce:

Actual results:

Expected results:

The current Firefox logos (stable, beta, nightly) for Mac are not in accordance with Apple's Human Guidelines:

https://developer.apple.com/design/human-interface-guidelines/macos/icons-and-images/app-icon/

While this isn't a bug, ideally the icon should be reworked to be semi-squared, or the current one enclosed in a semi square border.

I've seen other applications (Discord, Telegram, Anydesk, etc) do this after Big Sur was released, and wondered if Firefox will take the same route. It may be preferable not to do it if the icon will look worse.

See conversation in bug 1648386

Status: UNCONFIRMED → RESOLVED
Closed: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1648386
You need to log in before you can comment on or make changes to this bug.