Closed Bug 1706478 Opened 1 year ago Closed 1 year ago

Onboarding container is very tall in initial slide

Categories

(Firefox :: Messaging System, enhancement, P2)

enhancement

Tracking

()

VERIFIED FIXED
90 Branch
Iteration:
90.2 - May 3 - May 16
Tracking Status
firefox89 --- verified
firefox90 --- verified

People

(Reporter: j.heavener, Assigned: Mardak)

References

Details

(Whiteboard: [foxfooding][internal][proton-foxfooding][proton-onboarding] )

Attachments

(1 file)

Attached image fixed-height-slider.png

steps to reproduce/what did you do?

  • Setup: Theme set to Default (and system set to Dark), and 'browser.aboutwelcome.design' set to 'proton'
  • Visit about:welcome and start onboarding flow
  • View the Import step, observe the space below the pagination dots
  • View the Theme Selection step

expected behavior/ what did you think will happen?

  • There is a reasonable amount of space at at the bottom of the container

actual behavior/ what actually happened?

  • There is an excessive amount of space at the bottom of the container

additional notes

I think this is just fixed height since the second slide does take up the whole height of the container and it looks fine. This issue is just with the first slide. An argument could be made for a fixed height here to avoid the container jumping around. Notably this issue does not occur at mobile window sizes.

Whiteboard: [foxfooding][internal] [proton-foxfooding]

Design feedback was "Please ensure modal (white boxes) are the same size for import and theme selection screens"

Maybe the content should be spaced differently though?

Component: Foxfooding → Messaging System
Whiteboard: [foxfooding][internal] [proton-foxfooding] → [foxfooding][internal][proton-foxfooding][proton-onboarding]
Priority: -- → P2

Patch in bug 1698204 fixes this.

Assignee: nobody → edilee
Iteration: --- → 90.2 - May 3 - May 16
See Also: → 1698204

Other bug fixed by moving steps indicator to the bottom edge as well as pushing down buttons a bit too, so they're in the same positions on the latter screens.

https://hg.mozilla.org/mozilla-central/rev/88ca58d4c08e

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

Can this one be uplifted to Beta 89 please?

There's a win7 regression bug 1709805 as there's no steps indicator for the single center slide, so we'll need to fix that before uplifting this.

Regressions: 1709805

I have verified the following:

  • The Logo and the "Import headline" are displayed in the top half of the Upgrading modal.
  • The "Import from previous browser", the "Not now" button, and both indicators are displayed at the bottom of the Upgrading modal.

The verification was done using Firefox Nightly 90.0a1 (Build ID: 20210509213623) on Windows 10 x64, macOS 11.3.1, and Ubuntu Linux 20.04 x64.

Status: RESOLVED → VERIFIED

This enhancement was part of the work done on [PI-1013] Proton: Onboarding which was signed off as GREEN. Considering this I am changing the status for Firefox 89 to Verified.

You need to log in before you can comment on or make changes to this bug.