Many downloads show up as 1k, despite varying sizes; moz inserts http header onto beg. of file.

RESOLVED INVALID

Status

SeaMonkey
Download & File Handling
--
major
RESOLVED INVALID
15 years ago
13 years ago

People

(Reporter: Eric Perez, Assigned: Blake Ross)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2a) Gecko/20020910

While downloading many different type of files (.zip, .pdf., .exe, etc) from
various sites, the files are listed as being 1k in download manager. What it's
doing is adding the http headers to the beginning of the file somehow, which
corrupts the file so it's unopenable. This also happened in version 1.1 final. 

Here is a short dump of the first part of a .PDF file I downloaded today:


-----------------------------------------------------------------------

5b4
HTTP/1.1 200 Document follows
Server: Domino-Go-Webserver/4.6.2.6
Date: Wed, 25 Sep 2002 05:12:44 GMT
Connection: keep-alive
Accept-Ranges: bytes
Content-Type: application/pdf
Content-Length: 432188
Last-Modified: Thu, 31 May 2001 19:23:07 GMT

%PDF-1.2
%ту╧╙
1 0 obj
<<
/CreationDate (D:191010531120214)
/Producer (\376\377\000A\000c\000r\000o\000b\000a\000t\000
\000D\000i\000s\000t\000i\000l\000l\000e\000r\000 \0003\000.\0000\0002)
/Subject (1286053)
/Keywords ()
/Author (lcuratol)
/Creator (Adobe PageMaker 6.52)
/Title (1286053)
>>
endobj
3 0 obj
<<
/Length 136148
/Filter /FlateDecode
>>
stream
HЙdWKП^╖
▌Ё╕K{17ї▐жн

-----------------------------------------------------------------------

So I've been having to use Mozilla for my web browser and then IE (shudder) to
download my files.

Reproducible: Sometimes

Steps to Reproduce:
1. Click on a link to a file.
2. Watch the size progress go up in download manager.
3. After the file is downloaded, the final 'transfered' size becomes 1k.

Actual Results:  
The file downloaded completely, but with the http header attached to the file,
making is unusable, except by extraction by a hex editor.

Expected Results:  
Downloaded the file without the http header attached to it.

All of the .zip files on this page downloaded the way I described above:

http://www.nu2.nu/bootdisk/modboot/#create

Other sites have also done the same thing, such as pdf files I downloaded from
www.audiovox.com.
QA Contact: sairuh → petersen

Comment 1

15 years ago
Thank you for contribution but please do not put several issues into one bugreport.
I suggest you to read http://www.mozilla.org/quality/bug-writing-guidelines.html
before reporting.

First part of your report seems to be duplicate of bug 149237.
And there is no reproducing procedure for  the second part provided. Please
create new detailed bugreport for it.

Marking as Invalid...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.