Closed Bug 1706591 Opened 5 months ago Closed 4 months ago

Bad contrast on site information menu in dark theme

Categories

(Firefox :: Menus, defect, P2)

Firefox 90
x86_64
Linux
defect

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox88 --- disabled
firefox89 --- affected
firefox90 --- affected

People

(Reporter: i, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-door-hangers] [priority:2b])

Attachments

(1 file)

STR:

  1. Set to dark theme on Firefox (Dark or Alpenglow)
  2. VIsit "Site information" > "Clear cookies and site data..."

ER: Decent text color.
AR: As shown by the attachment.

It's probably related to the case when I use a dark KDE desktop theme, but I can also reproduce this when installing Firefox in a Docker container, where only X11 session is shared.

Which versions of Firefox are you seeing this with? The screenshot suggests nightly, and your bug comment suggests you can also reproduce with release - or was that nightly, too?

Severity: -- → S2
Flags: needinfo?(i)
Whiteboard: [proton-door-hangers]

(In reply to :Gijs (he/him) from comment #1)

Which versions of Firefox are you seeing this with? The screenshot suggests nightly, and your bug comment suggests you can also reproduce with release - or was that nightly, too?

It is firefox-trunk [1] so that's also nightly. This problem seems to be on every revision with the proton-door-hangers enabled.

  1. https://launchpad.net/~ubuntu-mozilla-daily/+archive/ubuntu/ppa
Flags: needinfo?(i)
Priority: -- → P2
Whiteboard: [proton-door-hangers] → [proton-door-hangers] [priority:2b]

I have managed to reproduce in Fedora 33 and Ubuntu 20 with Nightly v90.0a1 and Beta v89.0b3.

When opening the Site Information Panel and hovering over the "Clear cookies and site data" the font color of the text changes to dark-
gray incorrectly.

Status: UNCONFIRMED → NEW
Has Regression Range: --- → irrelevant
Has STR: --- → yes
Ever confirmed: true
See Also: → 1704195

This is no longer an issue on Ubuntu 18.04 x64 using Beta 89.0b8 and latest Nightly 90.0a1. Tested with Dark or Alpenglow themes.

Status: NEW → RESOLVED
Closed: 4 months ago
Depends on: 1708690
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.