Closed Bug 170677 Opened 20 years ago Closed 19 years ago

A new icon for Firebird

Categories

(Firefox :: General, enhancement)

x86
Windows XP
enhancement
Not set
normal

Tracking

()

VERIFIED FIXED
Firefox1.0

People

(Reporter: fredbezies, Assigned: kerz)

References

Details

Attachments

(1 file, 6 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20020924 Phoenix/0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20020924 Phoenix/0.1

First of all, thanks for pheonix ! I really love it :-)

As I am using both Phoenix and Mozilla, what about a new icon for Phoenix ? ;-)

I will be better and simpler for testers / users.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Attached image my Phoenix icon (obsolete) —
Attached image Phoenix icon based on about image (obsolete) —
I'm attaching an icon that contains both 16x16 and 32x32 16-color versions for
use as the application icon and in the taskbar. It is based on the phoenix
image on help about.
Confirming bug. It is confusing that Phoenix uses the same icon as Mozilla.
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 171299 has been marked as a duplicate of this bug. ***
I think it is pretty good. I have Mozilla, Phoenix, and Netscape 7 on my
workstation.  I was also able to force this into the Phoenix executable so it
show up in the upper left corner of the program using <a
href=http://www.users.on.net/johnson/resourcehacker> ResourceHacker</a>.
*** Bug 171349 has been marked as a duplicate of this bug. ***
I like Robert Wellman's icon. Any way it can be made more 3D?
Joseph,

I am sure that someone could make the icon much better.  To tell you the truth
this is the first time I have had to make an icon of my own.  I will work on it
when I get a chance.  If anyone more talented than myself is interested in
reworking the icon I would love to see the result.  There probably also needs to
be a 16x16 x 16 color version.

-RLW
OS: Windows XP → All
*** Bug 171848 has been marked as a duplicate of this bug. ***
We're going to be getting new artwork for phoenix. The plan is to have a full
phoenix "look" and not something piecemeal like what we have now (with
throbbers, buttons and logo all from different artists). Bugs aren't the best
place to handle these kinds of issues (if you don't believe me then check out
some of the old seamonkey artwork bugs). 

If you're an artist interested in contributing a new look for phoenix please
email asa@mozilla.org with a sample of your work (preferably the "big 4" icons:
back, forward, reload, and stop). Thanks. 
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → INVALID
*** Bug 173904 has been marked as a duplicate of this bug. ***
*** Bug 206104 has been marked as a duplicate of this bug. ***
Some cool icons for Phoenix/Firebird ;-)

http://iconpacks.mozdev.org/phoenix/
Mass-verifying of old bugs.
Status: RESOLVED → VERIFIED
This bug is a thorn in my side. Phoenix is now named Firebird, and eventually 
will become "Mozilla Browser" when we transition to the new toolkit, but 
regardless, we need to have this icon available for now.
Status: VERIFIED → REOPENED
Resolution: INVALID → ---
Taking
Assignee: blaker → netdemonz
Status: REOPENED → NEW
Accepting. I don't want two Mozilla icons in my taskbar.
Status: NEW → ASSIGNED
Attachment #100952 - Attachment is obsolete: true
Attachment #100916 - Attachment is obsolete: true
Attachment #100744 - Attachment is obsolete: true
Comment on attachment 101078 [details]
Icon based on Grayrest's latest update.  Includes 16x16, 32x32, and 48x48

Renaming it to mozilla.ico
Place in:
mozilla\browser\app, and we are done.
Attachment #101078 - Attachment filename: phoenix.ico → mozilla.ico
Attachment #101078 - Flags: review?
Comment on attachment 101078 [details]
Icon based on Grayrest's latest update.  Includes 16x16, 32x32, and 48x48

Asking for review. Of course, this icon will only matter until Firebird becomes
"Mozilla Browser" but it should make things less messy for testers and
developers.
Attachment #101078 - Flags: review? → review?(bryner)
OS: All → Windows XP
Target Milestone: --- → Firebird0.7
Summary: A new icon for Pheonix. → A new icon for Firebird
I'm not a fan of the current style of mozilla icons, let's find something better.
What do you have in mind for a new style, just a clear background or a clear
background with a 1 px box around it perhaps? I imagine when Firebird becomes
"Mozilla Browser" this icon would need to be changed anyway. So this would only
be a temporary fix to solve an immediate issue that exists until Firebird
becomes Mozilla.
On #14 I placed a link to http://iconpacks.mozdev.org/phoenix/

I think they are very cool ;-)
Place in:
mozilla\browser\app

Do you know who made this? scratch?

Notice that we will have to revert back to Grayrest's icons or some replacment
when Firebird becomes Mozilla Browser. Let's just get this in for now so we
don't have two Mozilla icons on the desktop or wherever you put your icons.

I also think we should come up with a standard for naming the icons when that
happens. They are named two or three different ways.
Attachment #101078 - Attachment is obsolete: true
Attachment #101078 - Flags: review?(bryner)
Attachment #127589 - Flags: review?(bryner)
Does this also cover the icons for documents & images associated to Firebird?

I assume the newly attached icon ( attachment 127589 [details] ) is indeed the version of
the icons which contains all sizes and are compatible with Windows XP etc?
In other words, is this icon the one downloadable from the site?
http://iconpacks.mozdev.org/downloads/phoenix/phoenix.ico
Yes it is from http://iconpacks.mozdev.org/downloads/phoenix/phoenix.ico, and
I'm not sure what it will do for associations, but at least you'll see an icon
other than Mozilla in your startmenu and quicklaunch and not get the two confused.

This also won't help Linux users.
#24: On the site you could see at the end of the main page a seccion with the
Credits

On "Extra stuff" section you could get a splash screen and other icons.

On the webpage there are a lot of icons, you could see all using the links
    * Complete Build »
    * Alpha Build »
    * Alternate Build »
( <a
href="http://bugzilla.mozilla.org/attachment.cgi?id=127589&action=view">attachment
127589 [details]</a> ) was made by <a href="http://www.phoenity.com">cheeaun</a>.  I just
helped with winxp-izing it.
comment #27: I am aware of the existance of the icons for documment 
associations. All I am saying is I don't know of any way to easily change these 
icons in the suite in the way that you can change the program icon. I also 
don't believe it is something that is worth the trouble since we are going to 
have to replace them again in a few months when Firebird becomes Mozilla. If 
you really want to do this, I suggest filing a new bug since that is a seperate 
issue and affects a different part of the code than changing the program icon, 
which is a CVS one-liner.

BTW: I'm on vacation 6 hours north of Toronto, Ontario and don't know if I will 
be able to respond to any more comments until after 7/28.
Attached image A new, clean firebird icon (obsolete) —
I don't know whether mine would be considered:
http://forums.mozillazine.org/viewtopic.php?t=15173
While this "bug" it's not "fixed" everybody could install this extension ;-)

http://texturizer.net/firebird/extensions.html#Fb%20Window%20Icon%20Adder
That is a very useful extension. Should that same set be used to replace current?
Agree to Comment #31.
It should be default icon to FB.
-> kerz
Assignee: netdemonz → kerz
Status: ASSIGNED → NEW
Target Milestone: Firebird0.7 → Firebird1.0
*** Bug 171349 has been marked as a duplicate of this bug. ***
Final icon, approved by ben.
Attachment #127589 - Attachment is obsolete: true
Attachment #127942 - Attachment is obsolete: true
Icon checked in.
Status: NEW → RESOLVED
Closed: 20 years ago19 years ago
Resolution: --- → FIXED
The icon does not have a 48x48 size or biger included, this will make it look
ugly in some WinXP an probably Linux settings :(
What about comment 11? Wasn't the plan to make the icon work with the new theme
(in other words an icon designed by Arvid Axelsson)?
A 48x48 icon was added yesterday.  Brian Ryner has also taken care of linux icons.
Might as well verify this. I'd like to say that even though the various icons
people made for Firebird weren't chosen by the developers (I wasn't involved)
that checked in the icon, they are still nice. Also, I'm pretty sure from what
I've been hearing that Firebird will be renamed Mozilla when it replaces it and
revert back to some form of the dinosaur icon. Therefore, the Firebird and
Thunderbird icons you make (if this happens) will not be of much use and you
will have wasted work.

I'd love to see more application icons available for Mozilla, and perhaps even a
DLL holding a set of choices for people along with the association icons from
bug 214054.

The way icons are hooked up in the tree could be considered a hack at best, and
I feel this should really be cleaned up before we go and create more chaos. For
instance: bug 199576. See also bug 29303 about iconographic issues.
Status: RESOLVED → VERIFIED
Attachment #127589 - Flags: review?(bryner)
You need to log in before you can comment on or make changes to this bug.