Closed Bug 1706926 Opened 2 years ago Closed 2 years ago

msgWindow is undefined when adding *first* existing email account

Categories

(Thunderbird :: Account Manager, defect)

Thunderbird 89
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 1705272

People

(Reporter: b.bergman, Unassigned)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.72 Safari/537.36

Steps to reproduce:

In Thunderbird 89.0b1 (64-bit) beta:

  1. Click Add Mail Account... under AccountSettings tab
  2. Fill in name, email address and password
  3. Click Confihure manually...
  4. Fill in correct server FQDNs
  5. Click Re-test (with success)
  6. Click Done

Actual results:

A yellow message bar appears under the Remember password checkbox that says "msgWindow is undefined"

Extra info; After selecting Advanced config and clicking OK, the account is saved successfully (workaround)

Expected results:

I expect the account to be saved and to close the Account Setup tab

Hi, I have exactly the same problem. I want to create a new account because after yesterday's update my email account stopped sending. So receiving works but sending not. Only for that account, I have 5 other accounts and these work without a problem.

Hello b.bergman, does this require starting from blank with no accounts set up?

wfm on win10, 90.0a1 (2021-04-22) (64-bit)

I was also failing to reproduce this on win10, 89.0b1 (32-bit).

Once got this on beta: (trying to re-add an imap account which I already have, but it should tell me that, not this)
[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgAccountManager.createIncomingServer]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://messenger/content/accountcreation/verifyConfig.js :: verifyConfig :: line 70" data: no]

Flags: needinfo?(b.bergman)

(In reply to Thomas D. (:thomas8) from comment #2)

Hello b.bergman, does this require starting from blank with no accounts set up?

wfm on win10, 90.0a1 (2021-04-22) (64-bit)

I was also failing to reproduce this on win10, 89.0b1 (32-bit).

Once got this on beta: (trying to re-add an imap account which I already have, but it should tell me that, not this)
[Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIMsgAccountManager.createIncomingServer]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://messenger/content/accountcreation/verifyConfig.js :: verifyConfig :: line 70" data: no]

I haven't tested with setting up a second account, this was indeed with no accounts set up yet.
I have already reverted to 78.10.0 by now, because I ran into another issue. So I cannot test unfortunately.
If you were unable to reproduce then probably it only occurs on the first account, I doubt that the 64-bit version has anything to do with it.

Flags: needinfo?(b.bergman)

64bit would NOT be involved.

Thanks b.bergman for fast responses, that's helpful!

Confirming on 89.0b1 (64-bit), Win10, apparently exclusive to first account setup.

I reproduced using exactly reporter's steps from comment 0, starting from account actions menu button in account settings, configure manually etc., but maybe reduced steps are possible.
As reported, error message msgWindow is undefined does indeed appear in the UI on yellow feedback area.

There are dozens of console errors, including these:

Related errors:

mail.setup: verifyConfig failed: TypeError: msgWindow is undefined verifyConfig.js:154
mail.setup: error msgWindow is undefined accountSetup.js:919

Some probably unrelated errors

(before)
Uncaught ReferenceError: LoadPostAccountWizard is not defined
    onLoad chrome://messenger/content/accountUtils.js:452
    _contentTab_onLoad chrome://messenger/content/specialTabs.js:916
accountUtils.js:452:5

(after)
NS_ERROR_FAILURE: Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIURI.host] LoginAutoComplete.jsm:536
    startSearch resource://gre/modules/LoginAutoComplete.jsm:536
Severity: -- → S2
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: msgWindow is undefined when adding new email account → msgWindow is undefined when adding *first* existing email account

This is probably a duplicate of bug 1705272, which fixed the issue on 90.
I'm gonna test it and request uplift.

Thomas, can you confirm this is fixed on trunk?
It works for me.

Flags: needinfo?(bugzilla2007)

Another workaround to avoid this issue is also to open the Account Setup from anywhere else other then the Account Settings pane.

  • Main Tab > Email button
  • Menu Bar > File > New > Existing mail account
  • App Menu > New > Existing mail account
Keywords: regression
Whiteboard: [dupe of bug 1705272?]

(In reply to Alessandro Castellani [:aleca] from comment #7)

Thomas, can you confirm this is fixed on trunk?
It works for me.

Yes, I can now confirm that this does not happen on trunk (although error console is full of things of all patterns and colors...).
Wfm on 90.0a1 (2021-04-26) (64-bit).
Probably fixed by bug 1705272 as you say (although strangely the yellow error messages vary, here we don't have callback in that message), so uplift to beta would be good, we shouldn't fail on the first mile, regardless of method used.

Flags: needinfo?(bugzilla2007)

Confirming this as well.

Error Console spits this out:

11:44:10.086 mail.setup: verifyConfig failed: TypeError: msgWindow is undefined verifyConfig.js:154

11:44:10.087 NS_ERROR_FILE_UNRECOGNIZED_PATH: Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIFile.leafName] SearchIntegration.jsm:651
folderDeleted resource:///modules/SearchIntegration.jsm:651
verifyConfig chrome://messenger/content/accountcreation/verifyConfig.js:156
validateAndFinish chrome://messenger/content/accountcreation/accountSetup.js:1997
onCreate chrome://messenger/content/accountcreation/accountSetup.js:1949
open chrome://messenger/content/accountcreation/accountSetup.js:2228
onCreate chrome://messenger/content/accountcreation/accountSetup.js:1943
oncommand about:accountsetup:1

11:44:10.106 mail.setup: error msgWindow is undefined accountSetup.js:919

(In reply to Arthur K. [He/Him] from comment #10)

Confirming this as well.

Thanks Arthur for checking things out! Please always mention the exact version number of TB for which you're confirming.
Could you retest with 89.0b2? Should be fixed there by bug 1705272.

(In reply to Thomas D. (:thomas8) from comment #9)

Probably fixed by bug 1705272 as you say (although strangely the yellow error messages vary, here we don't have callback in that message), so uplift to beta would be good, we shouldn't fail on the first mile, regardless of method used.

Potential fix has been uplifted to 89.0b2 per Bug 1705272 Comment 29.

Flags: needinfo?(thee.chicago.wolf)

(In reply to Thomas D. (:thomas8) from comment #12)

(In reply to Arthur K. [He/Him] from comment #10)

Confirming this as well.

Thanks Arthur for checking things out! Please always mention the exact version number of TB for which you're confirming.
Could you retest with 89.0b2? Should be fixed there by bug 1705272.

(In reply to Thomas D. (:thomas8) from comment #9)

Probably fixed by bug 1705272 as you say (although strangely the yellow error messages vary, here we don't have callback in that message), so uplift to beta would be good, we shouldn't fail on the first mile, regardless of method used.

Potential fix has been uplifted to 89.0b2 per Bug 1705272 Comment 29.

Looks like it is working on 89.0b2 for me.

Flags: needinfo?(thee.chicago.wolf)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Whiteboard: [dupe of bug 1705272?]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.