Closed Bug 1706984 Opened 9 months ago Closed 9 months ago

Heartbeat Infobar - informational icon is missing

Categories

(Firefox :: Messaging System, defect, P1)

defect

Tracking

()

RESOLVED INVALID
Tracking Status
firefox-esr78 --- unaffected
firefox87 --- unaffected
firefox88 --- unaffected
firefox89 --- wontfix
firefox90 --- wontfix

People

(Reporter: simona.marcu, Assigned: mstriemer)

References

(Blocks 3 open bugs, Regression)

Details

(Keywords: regression, Whiteboard: [proton-infobars] [proton-icons])

Attachments

(1 file)

Affected platforms:
All

Affected versions:
Nightly 90.0a1
Firefox 89 beta 2

Pre-requisites:

  • make sure that Proton is ON.

Steps to reproduce:

  1. Launch Firefox.
  2. Install https://github.com/mozilla-extensions/normandy-devtools/releases
  3. Click the wrench icon
  4. From the top right corner of the page, click the environment button and select Stage
  5. Find recipe 1375 [cmuresan][pi-957] test heartbeat info bar
  6. Click the [...] button and click run
  7. Observe the Heartbeat Infobar.

Expected Results:
The Heartbeat should be properly displayed.

Actual Results:
The informational icon is missing (there used to be an "Information Notification" icon after the proton restyles, before the re-style it used to be a "heart" icon).

Notes:

  • Found commit message:
    Bug 1702201 - Fix Heartbeat info bar with proton enabled r=jaws

https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=bd702683bc3c0e964f915158dd03b8662bed429d&tochange=e64f3ba43f11e767f28f35d450337c9ec096d90d

Has Regression Range: --- → yes
Has STR: --- → yes
Blocks: proton-icons
Priority: -- → P2
Whiteboard: [proton-infobars] → [proton-infobars] [priority:2a] [proton-icons]
Priority: P2 → P1
Whiteboard: [proton-infobars] [priority:2a] [proton-icons] → [proton-infobars] [proton-icons]
Assignee: nobody → mconley
Attached image image.png

Are we certain there's actually supposed to be an icon here? This is a snapshot of a Heartbeat-like infobar from Figma, and I don't see an icon here.

jaws, do you know if removing the icon for the Heartbeat infobar in bug 1702201 was an intentional decision?

Flags: needinfo?(jaws)

Tyler, I discussed this with Betsy and Katie and according to the spec and discussion with them there isn't supposed to be an icon here since it's the "Firefox Informational" style. Mike included the screenshot from the spec above.

Is this still something we'd want to prioritize?

Flags: needinfo?(jaws) → needinfo?(tduzan)
Assignee: mconley → mstriemer

Thanks Mark and Mike, it looks like this matches spec so we can close this as invalid. I don't believe this needs to be re-addressed.

Status: NEW → RESOLVED
Closed: 9 months ago
Flags: needinfo?(tduzan)
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.