Closed Bug 1707177 Opened 7 months ago Closed 7 months ago

app menu badge for available update so tiny and blurry the arrow is unrecognizable

Categories

(Firefox :: Toolbars and Customization, defect, P2)

defect

Tracking

()

VERIFIED FIXED
90 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox88 --- unaffected
firefox89 --- verified
firefox90 --- verified

People

(Reporter: aryx, Assigned: emmamalysz)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-icons] [priority:2a][proton-appmenu-notifications] [proton-uplift])

Attachments

(4 files)

Firefox 90.0a1 20210422093115 on Windows 8.1 with 125% zoom on OS level

The app menu badge for an available update is so tiny and blurry that the arrow is unrecognizable.

Steps to reproduce:

  1. Install not the latest build.
  2. Disable automatic updates in the Settings (it might be necessary to start it with the -offline argument from the command line to be able to change this before it gets updated to the latest version).
  3. Go online (Alt key > menu File).
  4. Wait for update to get detected or trigger the background check (haven't the code at hand).
Component: Application Update → Toolbars and Customization
Product: Toolkit → Firefox
See Also: → 1704461
Blocks: proton-icons
Whiteboard: [proton-icons]
See Also: → 1686527

App menu and Fxa badges are simplified to small dot or triangle depending in the notification type (inside symbols removed). Please see attached mini spec for placement and details.
Circle/dot: notification-fill-12.svg
triangle: warning-fill-12.svg

Priority: -- → P2
Whiteboard: [proton-icons] → [proton-icons] [priority:2a]
Attachment #9218744 - Attachment mime type: application/octet-stream → image/png
Assignee: nobody → emalysz
Status: NEW → ASSIGNED
Whiteboard: [proton-icons] [priority:2a] → [proton-icons] [priority:2a][proton-appmenu-notifications]

We're going to need to introduce the new circle icon (notification-fill-12.svg), and make sure we use it here: https://searchfox.org/mozilla-central/rev/92be70819506d269df7c192bfbddc8c6ce581990/browser/themes/shared/customizableui/panelUI.inc.css#129

Pushed by emalysz@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c196bec7eed9
introduce notification icon for app menu button badge and apply it when update available r=mhowell
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

This is marked as priority2a, Is that something we should uplift to beta or do we let it ride the 90 train? Thanks

Flags: needinfo?(emalysz)

Since this is icon related work and low risk, I think it makes sense to request uplift

Flags: needinfo?(emalysz)

Comment on attachment 9219624 [details]
Bug 1707177, introduce notification icon for app menu button badge and apply it when update available

Beta/Release Uplift Approval Request

  • User impact if declined: Required for MR1 / Proton
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): No string changes. Introduces an svg file and small css changes
  • String changes made/needed: n/a
Attachment #9219624 - Flags: approval-mozilla-beta?
Whiteboard: [proton-icons] [priority:2a][proton-appmenu-notifications] → [proton-icons] [priority:2a][proton-appmenu-notifications] [proton-uplift]

Comment on attachment 9219624 [details]
Bug 1707177, introduce notification icon for app menu button badge and apply it when update available

Approved for 89 beta 9, thanks.

Attachment #9219624 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Hi, I was trying to confirm the fix on this issue and it seems that only the update available Badge has been updated to the green dot displayed on the Hamburger menu.. but in the case for the Unable to Update notification the Exclamation mark is still displayed inside the badge for warning sign.

Is this bug strictly related to the Update available notifications ? cause from the screenshots in Comment 1 the Warning sign should not have the exclamation mark inside the badge.

I will add a screenshot of this case.

Flags: needinfo?(emalysz)

Beta 89.0b9.

Hi Rares, this bug was just related to the update notification.

We're going to handle the warning icon in Bug 1707190.

Flags: needinfo?(emalysz)

oh Awesome, This issue is Verified as fixed in our Latest Nightly and Beta 89.0b9 on Windows, Mac and Ubuntu.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.