Closed Bug 1707378 Opened 7 months ago Closed 7 months ago

[Linux] Context menu doesn't follow the dark theme option

Categories

(Firefox :: Foxfooding, defect, P2)

Firefox 90
Desktop
Unspecified
defect

Tracking

()

RESOLVED DUPLICATE of bug 1692685
Tracking Status
firefox90 --- affected

People

(Reporter: pdehaan, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [foxfooding][community] [proton-foxfooding] [priority:2c] [proton-context-menus])

Firefox Version: Mozilla/5.0 (X11; Linux x86_64; rv:90.0) Gecko/20100101 Firefox/90.0
Window Size (inner width and height): 1137x748

Steps to Reproduce

  1. Opened the hamburger Menu, selected the ‘Add-ons and Themes’ option.
  2. Clicked the "Themes" button on the left
  3. Selected the "Light" theme option
  4. Right-clicked on the new tab page as well as a different page - all great
  5. Repeated Steps 1&2
  6. Selected the "Dark" theme option
  7. The context menu doesn't follow the browser's dark color scheme

Expected Behavior

I was expecting the context menu to respect the darker color scheme

Actual Behavior

The context menu remained a light color

This is a Linux issue, Jared is this a regression or were context menus already not supporting dark mode on Linux previously?

Flags: needinfo?(jaws)
Priority: -- → P2
Whiteboard: [foxfooding][community] [proton-foxfooding] → [foxfooding][community] [proton-foxfooding] [priority:2c]
Whiteboard: [foxfooding][community] [proton-foxfooding] [priority:2c] → [foxfooding][community] [proton-foxfooding] [priority:2c] [proton-context-menus]

On Linux we follow the OS theme for these menus, and always have. bug 1692685 tracks using the browser theme instead (though I bet that will upset Some People who like the current situation...)

Status: NEW → RESOLVED
Closed: 7 months ago
Flags: needinfo?(jaws)
Resolution: --- → DUPLICATE
Duplicate of bug: 1692685
Summary: Context menu doesn't follow the dark theme option → [Linux] Context menu doesn't follow the dark theme option
You need to log in before you can comment on or make changes to this bug.