Invalid "Accept-Language" field

VERIFIED WORKSFORME

Status

Core Graveyard
Profile: Migration
VERIFIED WORKSFORME
16 years ago
2 years ago

People

(Reporter: Jacob Sparre Andersen, Assigned: racham)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Build 2002051319 of Mozilla sends invalid "Accept-Language" fields.
The "Accept-Language" field should identify languages by their
two-letter ISO codes, and not by their names in some arbitrarily
chosen language. An example "Accept-Language" field from build
2002051319 of Mozilla:

   Faeroese, Swedish;q=0.87, Danish;q=0.75, Norwegian;q=0.62, Icelandic;q=0.50,
German;q=0.37, French;q=0.25, English;q=0.12

Comment 1

16 years ago
reporter: can you please try a more recent build, such as mozilla 1.1?

mozilla is designed to send the two character language codes, so i'm really
surprised to find that you're seeing this.  if you continue to see this problem
in mozilla 1.1, then perhaps there is something about your settings that is
confusing mozilla into sending such an Accept-Language header.  i'd recommend
creating a new profile to see if that doesn't help the problem.  thx!
Severity: critical → normal
(Reporter)

Comment 2

16 years ago
OK.  It appears that it was a defect configuration file (which may have been
due to a problem in the system that imported the configuration from my old
Netscape).  There ought to be some kind of validation of the language codes
before they are sent out, but now I have at least a personal work-around.

Comment 3

16 years ago
great, i'm glad that solved the problem for you.  what version of netscape did
you upgrade from?  is it possible that you can upload a copy of the "broken"
prefs.js file?  thx!
Assignee: darin → racham
Component: Networking: HTTP → Profile Migration
QA Contact: httpqa → ktrina

Comment 4

16 years ago
reporter, marking worksforme- if you do not agree, please reopen
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME

Comment 5

16 years ago
Verified WFM
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.