Closed Bug 1707543 Opened 2 years ago Closed 1 year ago

Thunderbird sends invalid IPv6 literal in HELO, rejected by Postfix

Categories

(MailNews Core :: Networking: SMTP, defect)

Thunderbird 89
defect

Tracking

(thunderbird_esr78 unaffected, thunderbird89+ fixed)

VERIFIED FIXED
90 Branch
Tracking Status
thunderbird_esr78 --- unaffected
thunderbird89 + fixed

People

(Reporter: bernie, Assigned: mkmelin)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/90.0.4430.85 Safari/537.36

Steps to reproduce:

Send an email to my STMP relay on port 465 (TLS) from a host with IPv6 connectivity.
I tried with both Thunderbird 89b1 (beta) and Thunderbird 90a1 (nightly).

Actual results:

Thunderbird shows:

Sending of the message failed.
The message could not be sent using Outgoing server (SMTP) smtp.sugarlabs.org
for an unknown reason. Please verify that your Outgoing server (SMTP) settings
are correct and try again.

Postfix on smtp.sugarlabs.org logged this error:

Apr 26 06:24:01 sunjammer postfix/smtpd[2901968]: connect from unknown[2405:XXXX:XXXX:XXXX::21]
Apr 26 06:24:03 sunjammer postfix/smtpd[2901968]: NOQUEUE: reject: RCPT from unknown[2405:XXXX:XXXX:XXXX::21]: 501 5.5.2 <[2405:XXXX:XXXX:XXXX::21]>: Helo command rejected: invalid ip address; from=<bernie@codewiz.org> to=<xxxx@gmail.com> proto=ESMTP helo=<[2405:XXXX:XXXX:XXXX::21]>

Expected results:

Postfix should have accepted the email as usual.

I've been using this server for years, and it runs Postfix 3.4.13-0ubuntu1 which was released one year ago.

Probably from bug 1701804 - https://hg.mozilla.org/comm-central/rev/512138052532

Though I wonder if that's not a Postfix bug...?

Keywords: regression

Actually, I see now...

Assignee: nobody → mkmelin+mozilla
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Regressed by: 1701804
Component: Untriaged → Networking: SMTP
Product: Thunderbird → MailNews Core
Target Milestone: --- → 90 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/3a0a98d2b98a
Correct IPv6 address family detection, to send correct IPV6 literal in SMTP HELO. r=rnons

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Comment on attachment 9218302 [details]
Bug 1707543 - Correct IPv6 address family detection, to send correct IPV6 literal in SMTP HELO. r=rnons

[Approval Request Comment]
Regression caused by (bug #): bug 1701804
User impact if declined: May not be able to send if using IPv6 connectivity
Testing completed (on c-c, etc.): just landed on c-c
Risk to taking this patch (and alternatives if risky): it's a trivial typo-kind of fix

Attachment #9218302 - Flags: approval-comm-beta?

Thank you for the quick fix, Magnus. I confirm that the problem is resolved in 90.0a1 2021-04-27.

Status: RESOLVED → VERIFIED

Thanks for verifying!

Comment on attachment 9218302 [details]
Bug 1707543 - Correct IPv6 address family detection, to send correct IPV6 literal in SMTP HELO. r=rnons

[Triage Comment]
Approved for beta

Attachment #9218302 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.