Closed Bug 1707591 Opened 1 year ago Closed 9 months ago

Update to black 21.11b1

Categories

(Firefox Build System :: Lint and Formatting, task)

task

Tracking

(firefox96 fixed)

RESOLVED FIXED
96 Branch
Tracking Status
firefox96 --- fixed

People

(Reporter: Sylvestre, Assigned: Sylvestre, Mentored)

References

(Blocks 1 open bug)

Details

(Keywords: good-first-bug)

Attachments

(5 files, 1 obsolete file)

There is a new version of black ( https://github.com/psf/black/releases/tag/21.4b0 ). We should use it.

The patch will look like:
https://hg.mozilla.org/mozilla-central/rev/c905933ae261
and might require a reformat of the tree like in
https://hg.mozilla.org/mozilla-central/rev/f5216758d874

Blocks: black
Mentor: sledru
Keywords: good-first-bug

As per bug 1740629 this might be a bit more urgent now?

Blocks: 1740629
Assignee: nobody → sledru
Status: NEW → ASSIGNED
Attachment #9250350 - Attachment description: WIP: Bug 1707591 - Update to black 21.10b0 r#linter-reviewers,gerad-majax → WIP: Bug 1707591 - Update to black 21.10b0 r#linter-reviewers,gerard-majax
Attachment #9250350 - Attachment description: WIP: Bug 1707591 - Update to black 21.10b0 r#linter-reviewers,gerard-majax → Bug 1707591 - Update to black 21.10b0 r#linter-reviewers,gerard-majax
Attachment #9250350 - Attachment description: Bug 1707591 - Update to black 21.10b0 r#linter-reviewers,gerard-majax → Bug 1707591 - Update to black 21.10b0 r?#linter-reviewers,gerard-majax
Pushed by sledru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0269849fd7ef
Update to black 21.10b0 r=gerard-majax
https://hg.mozilla.org/integration/autoland/rev/a730ab2d0dbe
ride along - reformat the tree with black 21.10b0 r=webdriver-reviewers,whimboo,gerard-majax

Backed out for causing python mozlint failures on test_yaml.py.

Push with failures

Failure log

Backout link

Flags: needinfo?(sledru)

The error is
[task 2021-11-12T16:19:42.726Z] 0:59.36 Unable to match yaml regex against output: black 21.10b0 has requirement typed-ast>=1.4.2; python_version < "3.8", but you have typed-ast 1.4.1.

See Also: → 1741906
Summary: Update to black 21.4b0 → Update to black 21.10b0
Attachment #9250350 - Attachment description: Bug 1707591 - Update to black 21.10b0 r?#linter-reviewers,gerard-majax → Bug 1707591 - Update to black 21.11b1 r?#linter-reviewers,gerard-majax
Attachment #9250531 - Attachment is obsolete: true
Summary: Update to black 21.10b0 → Update to black 21.11b1
Pushed by sledru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/45dae660af98
Parse the new output of black --version r=linter-reviewers,ahal
https://hg.mozilla.org/integration/autoland/rev/3829d10ed633
Update to black 21.11b1 r=gerard-majax
https://hg.mozilla.org/integration/autoland/rev/f105477d372d
ride along - reformat the tree with black 21.10b0 r=ahal,webdriver-reviewers,perftest-reviewers,whimboo,gerard-majax,alexandru.irimovici
https://hg.mozilla.org/integration/autoland/rev/05fa7ff67318
ride along: update of the pylint dep to match black's r=linter-reviewers,ahal
https://hg.mozilla.org/integration/autoland/rev/3de4e3bcca1c
ride along: update of the flake8 dep to match black's r=linter-reviewers,ahal
Duplicate of this bug: 1740629
You need to log in before you can comment on or make changes to this bug.