Accessing 'float' property from dom generates a javascript error

VERIFIED INVALID

Status

()

Core
DOM: CSS Object Model
VERIFIED INVALID
16 years ago
14 years ago

People

(Reporter: Vladimir Ermakov, Assigned: jst)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
The following code generates a javascript error but should pop up an alert with
the value of the float property - "right".

<DIV id="test" style="float: right">Test</DIV>
<SCRIPT>
alert(document.getElementById("test").style.float);
</SCRIPT>

Error: missing name after . operator
Source Code:
alert(document.getElementById("test").style.float);
(Reporter)

Comment 1

16 years ago
Created attachment 100589 [details]
testcase
INVALID.  float is a reserved keyword in many languages, and thus you must use
.cssFloat and not .float.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

16 years ago
Ok. Verifying.
Status: RESOLVED → VERIFIED

Comment 4

14 years ago
*** Bug 244281 has been marked as a duplicate of this bug. ***

Comment 5

14 years ago
*** Bug 204235 has been marked as a duplicate of this bug. ***

Comment 6

14 years ago
*** Bug 74602 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.