Bug 170804 (sport.onet.pl)

sport.onet.pl - Live Commentator doesn't work - Java applet issue

RESOLVED FIXED in Future

Status

Tech Evangelism Graveyard
Polish
P4
normal
RESOLVED FIXED
16 years ago
3 years ago

People

(Reporter: Peter Bartecki, Assigned: Jacek Piskozub)

Tracking

({top500})

unspecified
Future
top500

Details

(Whiteboard: [bug248549notfixed], URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; PL; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; PL; rv:1.2a) Gecko/20020910

Live Sport Commentator Java applet which is available at
http://sport.onet.pl/live.html (only some of the events are commented) fails to
load in Mozilla.

Reproducible: Always

Steps to Reproduce:
1. Open http://sport.onet.pl/live.html


Actual Results:  
Applet fails to load

Expected Results:  
We want to listen.. ;) - spoken on behalf of Sport Fans.

Errors from the Console:

load: class onet.komentator.Komentator2.class not found.

java.lang.ClassNotFoundException: java.io.FileNotFoundException:
http://sport.onet.pl/onet/komentator/Komentator2/class.class

   at sun.net.www.protocol.http.HttpURLConnection.getInputStream(Unknown Source)

   at sun.plugin.protocol.jdk12.http.HttpURLConnection.getInputStream(Unknown
Source)
...... 

 Comments from our dev team member, Gabriel:

Please look at: 

1) how code attribute is passed:

<applet code=onet.komentator.Komentator2.class height=1 name=TestClient width=1
MAYSCRIPT>

 Should be either class name: onet.komentator.Komentator2 or
 Path to it: onet/komentator/Komentator2.class

2) They also use: 

<param NAME="useslibrarycodebase" VALUE="komentator.cab">  - not sure if and to
which extent Java handles .cab files.


Discussion about this bug in Polish:
http://mozillapl.org/phpBB2/viewtopic.php?p=4303#4303
(Assignee)

Comment 1

16 years ago
Confirming and accepting.

Yes, I believe it's one of the reasons you gave (or both). Will investigate.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P4
Target Milestone: --- → Sep
(Assignee)

Updated

16 years ago
Target Milestone: Sep → Oct
(Assignee)

Comment 2

16 years ago
The result of my investigation: 

The site uses Microsoft model of signing a Java applet. The signing is necessary
if the applet is supposed to leave the Java "sandbox" but signed cab files
should be served only to IE browsers. Mozilla (and other browsers using Sun Java
plugin) should be served a jar file signed using the Sun signing model.

For Sun documentation on signing Jar files, see
http://developer.java.sun.com/developer/Books/javaprogramming/JAR/sign/
(Assignee)

Comment 3

16 years ago
Evangelic letter sent to sport@onet.pl and webmaster@onet.pl
Target Milestone: Oct → Dec
(Assignee)

Updated

16 years ago
Alias: sport.onet.pl
(Assignee)

Comment 4

16 years ago
Second evangelic letter sent.
Target Milestone: Dec → Feb
(Assignee)

Comment 5

15 years ago
No progress. Futuring the bug.
Target Milestone: Feb → Future
Summary: Live Commentator at sport.onet.pl doesn't work - Java applet issue → sport.onet.pl - Live Commentator doesn't work - Java applet issue
tech evang june 2003 reorg
Component: Europe: Central → Polish
Target Milestone: Future → ---
(Assignee)

Updated

15 years ago
Target Milestone: --- → Future
The same problems occur with chats on onet.pl.
They are still using soon-to-be-illegal Microsoft Java...

At the moment instead of trying to load MS Java, that site gives Mozilla's user
info:

"Attention!
Microsoft Internet Explorer ver. 5.0 or better
is needed for proper work of this service. Sorry."

Jacek: basing on success with bug 219953, meaby it's time for another letter?
I've just added Maciej Maciejowski from Onet as CC on this bug.
Whiteboard: [bug248549notfixed]

Updated

13 years ago
Keywords: top500
FIXED according to http://osiolki.net/poprawiony/liveonet (Osiolki.net is a
Polish web standards evangelism team, consisting of Mozilla, Opera and
Konqueror/Safari users)

The applet now loads properly in Sun Java VM and is said to work ok in Firefox
and Opera. It would be nice to check it during real transmissions.

They're still saying that "it works best with IE and MS JVM", though.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.