Closed Bug 1708281 Opened 7 months ago Closed 7 months ago

Sometimes website info menu (padlock) glitch or unresponsive

Categories

(Firefox :: Site Identity, defect, P2)

Firefox 89
Unspecified
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1708869

People

(Reporter: sophia.albert, Unassigned, NeedInfo)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-address-bar] [priority:2a])

Attachments

(1 file)

Attached image uuuuuuu.PNG

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:78.0) Gecko/20100101 Firefox/78.0

Steps to reproduce:

I can not reproduce the bug (Firefox Windows 89.0b5) . click on padlock button to see website info menu

Actual results:

(see image) button displays Firefox text and does not respond

Component: Untriaged → Address Bar
OS: Unspecified → Windows 10

Are there any errors in the browser console when this happens, or when you click the button and nothing happens? (You can open the console from Tools > Browser Tools > Browser Console)

Which version of Firefox does this happen in? The bug's Version field is set to 89 and your screenshot looks like 89, but you say "I can not reproduce the bug (Firefox Windows 89.0b5)".

There's a similar problem in bug 1708158.

Flags: needinfo?(sophia.albert)
See Also: → 1708158

I did not think to open the console! I'll think about it next time.

It was on Firefox 89.0b5

Flags: needinfo?(sophia.albert)

Thanks.

It's not clear that this is Proton related but it may be, so I'll mark it blocking proton-address-bar so it's on the radar. The similar bug 1708158 is also blocking.

Whiteboard: [proton-address-bar]

I have the bug again (on youtube.com again). Console :

Uncaught TypeError: can't access property "isBuiltInRoot", issuerCert is undefined
_hasCustomRoot chrome://browser/content/browser-siteIdentity.js:802
refreshIdentityPopup chrome://browser/content/browser-siteIdentity.js:1007
_openPopup chrome://browser/content/browser-siteIdentity.js:1235
handleIdentityButtonEvent chrome://browser/content/browser-siteIdentity.js:1227
onclick chrome://browser/content/browser.xhtml:1
browser-siteIdentity.js:802:12
_hasCustomRoot chrome://browser/content/browser-siteIdentity.js:802
refreshIdentityPopup chrome://browser/content/browser-siteIdentity.js:1007
_openPopup chrome://browser/content/browser-siteIdentity.js:1235
handleIdentityButtonEvent chrome://browser/content/browser-siteIdentity.js:1227
onclick chrome://browser/content/browser.xhtml:1

Thank you, that may be useful. Based on the stack, it looks like the button is in the wrong state, so it can't do what it normally does when you click it. That makes sense of course since visually the button is in the wrong state. The more important question is why.

Priority: -- → P2
Whiteboard: [proton-address-bar] → [proton-address-bar] [priority:2a]

Johann, can you help dig into this? This seems potentially bad.

Component: Address Bar → Site Identity
Flags: needinfo?(jhofmann)
See Also: → 1708869

Hm. Dana, are you aware of any recent changes that could cause succeededCertChain to be empty through a race (seems to fail here https://searchfox.org/mozilla-central/rev/083983b7f09b00cdfe4f70396e39ea4f8a1735e1/browser/base/content/browser-siteIdentity.js#796)?

I asked for a mozregression in bug 1708869, maybe that clears things up.

Flags: needinfo?(jhofmann) → needinfo?(dkeeler)

I still have the bug on Linux with the last Firefox 89.0b7.
More details : there I have the bug on the site google.com, the button works on my other tabs, unless it's a tab on google.com domain( even if it's a different address or if i open new tab with google.com domain).

(and I have nothing displayed in the console from now on)

There have been some changes in that general area recently, but nothing's really jumping out at me. A regression range for this bug would be helpful, assuming it's not the same as bug 1708869.

Sophia - can you use https://mozilla.github.io/mozregression/ to narrow down when this changed? Thanks!

Flags: needinfo?(dkeeler) → needinfo?(sophia.albert)

Most likely a duplicate of Bug 1708869. It's showing the same behavior where the identity UI doesn't update properly because of missing cert info.

Status: UNCONFIRMED → RESOLVED
Closed: 7 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1708869
You need to log in before you can comment on or make changes to this bug.