Closed Bug 1708451 Opened 5 months ago Closed 4 months ago

[Proton] The highlight on "Don't save" button from the Save login panel is not correctly displayed

Categories

(Toolkit :: Password Manager, defect, P2)

defect

Tracking

()

VERIFIED FIXED
90 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox88 --- unaffected
firefox89 --- wontfix
firefox90 --- verified

People

(Reporter: oana.botisan, Assigned: mconley)

References

(Blocks 2 open bugs)

Details

(Keywords: regression, Whiteboard: [proton-door-hangers] [priority:2b])

Attachments

(4 files)

Attached image image.png

Affected versions

  • Firefox 89.0b5
  • Firefox 90.0a1

Affected platforms

  • Windows 10 x64
  • Ubuntu 18.04 x64

Steps to reproduce

  1. Go to facebook.com.
  2. Write credential in the fields and click in "Log In".
  3. Navigate the login panel using keyboard.

Expected result

  • The highlight on "Don't save" button is correctly displayed.

Actual result

  • The highlight on "Don't save" button is not correctly displayed.

Regression range

Additional notes

  • Please look at the attached image.
Attached image Spec screenshot

Hi Oana,

I'm confused - this looks like it's per spec, but am I missing something? Which part of the highlight is wrong?

Flags: needinfo?(oana.botisan)
Attached image image (2).png

That was the issue... it looked like a bug, especially because the highlight on the arrow looks different, cleaner.
We didn't see the specs for this part. Can you please provide us with a link to this? Thank you.

Flags: needinfo?(oana.botisan)

Okay, redirecting to KatieC. The focus ring looks to spec to me, but let's double-check that the spec is supposed to show a difference between the left-part of the split button and the right.

Flags: needinfo?(kcaldwell)
Has Regression Range: --- → yes
Has STR: --- → yes
Whiteboard: [proton-door-hangers]

I spoke to KatieC about this. While it's true we're to the Figma spec here, the intention was to have the focus ring be a uniform width around the left side of the split button.

So this is a legitimate bug.

Flags: needinfo?(kcaldwell)
Severity: S3 → S4
Priority: -- → P3
Priority: P3 → P2
Whiteboard: [proton-door-hangers] → [proton-door-hangers] [priority:2b]
Assignee: nobody → mconley
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/eacb24786032
Temporarily boost z-index of main part of splitbutton when showing its focus ring. r=Itiel,desktop-theme-reviewers
Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

I verified the fix using latest Nightly 90.0a1 on Windows 10 x64 and Ubuntu 18.04 x64. The issue is not reproducing anymore.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.