Closed Bug 1708534 Opened 2 months ago Closed 1 month ago

Input text colour should be primary and not secondary colour in Edit Bookmarks panel

Categories

(Firefox :: Bookmarks & History, defect, P2)

defect

Tracking

()

VERIFIED FIXED
90 Branch
Tracking Status
firefox89 --- verified
firefox90 --- verified

People

(Reporter: amylee, Assigned: mconley)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-door-hangers] [priority:2a] [proton-uplift])

Attachments

(2 files, 1 obsolete file)

Title text colour should be primary and not secondary colour in Edit Bookmarks panel when you input text in the text field. Currently it's set to secondary text colour in the Titles input field. When you type in "Tags" it should also be primary text colour.

Light them text - #15141A
Dark theme text - #FBFBFE

Summary: Title text colour should be primary and not secondary colour in Edit Bookmarks panel → Input text colour should be primary and not secondary colour in Edit Bookmarks panel
Severity: -- → S3
Whiteboard: [proton-door-hangers]
Priority: -- → P2
Whiteboard: [proton-door-hangers] → [proton-door-hangers] [priority:2a]
Assignee: nobody → emalysz
Status: NEW → ASSIGNED
Assignee: emalysz → nobody
Status: ASSIGNED → NEW

Comment on attachment 9221443 [details]
Bug 1708534, increase spacing beneath labels in edit bookmark panel

Revision D114903 was moved to bug 1708424. Setting attachment 9221443 [details] to obsolete.

Attachment #9221443 - Attachment is obsolete: true
Assignee: nobody → mconley

It looks like we erroneously used the placeholder colour for the dark theme
input colour. This updates the dark theme to use the correct colour. It also
updates the light theme to use the same input colours as defined in the
light variation of the system theme.

Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/633b705d14eb
Use the specified input colours for dark and light built-in themes. r=jaws
Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

Can we please uplift to Beta 89?

Comment on attachment 9221644 [details]
Bug 1708534 - Use the specified input colours for dark and light built-in themes. r?jaws!

Beta/Release Uplift Approval Request

  • User impact if declined: Users will get slightly incorrect colours for input fields in the browser UI for the built-in light and dark themes.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Just updates some colour definitions in our theme manifests - very low risk.
  • String changes made/needed: None.
Attachment #9221644 - Flags: approval-mozilla-beta?
Whiteboard: [proton-door-hangers] [priority:2a] → [proton-door-hangers] [priority:2a] [proton-uplift]

Comment on attachment 9221644 [details]
Bug 1708534 - Use the specified input colours for dark and light built-in themes. r?jaws!

Approved for 89 beta 15, thanks.

Attachment #9221644 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Flags: qe-verify+
QA Contact: ciprian.georgiu
QA Whiteboard: [qa-triaged]

I've reproduced the bug using the info provided in comment 0, on an affected Nightly build (2021-04-29).

The issue is verified as fixed on the latest builds: Beta 89.0b15 and Nightly 90.0a1. Tested under macOS 10.15, Windows 10 x64 and Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.