Closed Bug 1708542 Opened 3 years ago Closed 9 months ago

There is a margin in the close, maximize/restore and minimize buttons. Putting the cursor to the top right edge of the screen makes hard to select the close button when the window is maximized

Categories

(Core :: Widget: Gtk, defect, P3)

Firefox 89
defect

Tracking

()

RESOLVED DUPLICATE of bug 1857183

People

(Reporter: mi2rivtj, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:88.0) Gecko/20100101 Firefox/88.0

Steps to reproduce:

  1. Maximize the window;
  2. Put the cursor at the top edge of the screen.

Actual results:

There's an unnecessary margin that is not preset in other GTK apps. This margin makes selecting the close button (by using the screen top right edge) difficult when the window is maximized.

Expected results:

Other apps like Gnome Disks and Gnome Clocks doesn't have this extra margin. Firefox should follow that too.

Version: Firefox 88 → Firefox 89

I forgot to mention: this happens in other themes. In the above image, I was using Qogir. But this happens with Arc, Breeze, Adwaita etc.

The Bugbug bot thinks this bug should belong to the 'Core::Widget: Gtk' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Widget: Gtk
Product: Firefox → Core

I guess this is not GTK bug. In modern window systems users (theme makers) gain control over window title rendering. And one of them make window control buttons without margin, other with margin. For example: there are several "MacOS" themes for KDE Plasma. Some of them came with this annoying margin, other without it.

Blocks: gtktitlebar
Priority: -- → P3

I can't reproduce with Firefox 88 unless I disable title bar, so title bar was either user disabled or disabled as default in this Ubuntu release.

Status: UNCONFIRMED → RESOLVED
Closed: 9 months ago
Duplicate of bug: 1857183
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: