Closed Bug 1708548 Opened 3 years ago Closed 3 years ago

My bookmark menu shows repeating horizontal separators

Categories

(Firefox :: Menus, defect, P3)

Firefox 89
Desktop
Unspecified
defect

Tracking

()

RESOLVED INVALID

People

(Reporter: pdehaan, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [foxfooding][internal] [proton-foxfooding] [proton-doorhangers])

Attachments

(3 files)

This comment is copy/pasted from a community issue filed during the Foxfooding program.


Firefox Version: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:90.0) Gecko/20100101 Firefox/90.0
Window Size (inner width and height): 1752x884

Steps to Reproduce

Per https://docs.google.com/document/d/1CnlnbZkR-meIFR7bSZh1GrO1vt_qbDCKvWpObt8-ZIk/edit#heading=h.si9l069aihrr I added the bookmarks menu to my panel and tried opening it. The content is super weird -- lots of obsolete bookmarks (probably taken by mistake) and most strangely a large number of horizontal separators which came out of nowhere.

Expected Behavior

Ideally a nice clean view of recent bookmarks that I want to see and a minimal number of horizontal separators where it makes sense.

Actual Behavior

This is probably more of a UX issue but it seems like this menu is prone (for an old profile like mine where people aren't constantly curating their bookmarks) to accumulate cruft and strange things (like bogus horizontal separators).

Attached image User screenshot
Attached image User screenshot 2

Suggested that I try against release 88 with the same profile and let us know if bookmarks list is the same there, or not, in the bug that was filed. Setting an NI to remind me to do this

Flags: needinfo?(wlachance)
Summary: My bookmark menu looks super weird → My bookmark menu shows repeating horizontal separators

Tried it with 88 and the same profile. Looks the same

Flags: needinfo?(wlachance)

This doesn't appear to be an MR1 regression since it reproduces in Release

Priority: -- → P3
Whiteboard: [foxfooding][internal] [proton-foxfooding] → [foxfooding][internal] [proton-foxfooding] [proton-doorhangers]
Component: Foxfooding → Menus

The old bookmarks are probably out of our control, these are still bookmarks that maybe the user has just forgotten about. I'm not sure of the cause of having multiple separators but that can also come from user error. They could either be added adjacent or become adjacent after items between two separators are removed.

As awkward as this looks, I don't think this is a bug, unless we consider potentially removing separators if they are adjacent to another. I'm not sure what action should trigger this though.

I'm not really sure what to do here, so I'm going to choose with marking this as "invalid" since it is generally a problem created by the user.

Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: