Closed Bug 1708821 Opened 5 months ago Closed 4 months ago

Intermittent PROCESS-CRASH | Main app process exited normally | application crashed [@ CoreFoundation + 0x9f1e]

Categories

(Core :: Graphics: Text, defect)

defect

Tracking

()

RESOLVED FIXED
90 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox88 --- unaffected
firefox89 --- unaffected
firefox90 --- fixed

People

(Reporter: intermittent-bug-filer, Assigned: jfkthame)

References

(Regression)

Details

(Keywords: crash, intermittent-failure, regression, Whiteboard: [stockwell needswork:owner])

Crash Data

Attachments

(1 file)

Filed by: ncsoregi [at] mozilla.com
Parsed log: https://treeherder.mozilla.org/logviewer?job_id=338335179&repo=autoland
Full log: https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/ESGhVGY2TR29R-dwFtmtSA/runs/0/artifacts/public/logs/live_backing.log


[task 2021-04-30T18:31:38.941Z] 18:31:38     INFO - mozcrash Saved minidump as /Users/cltbld/tasks/task_1619806330/build/blobber_upload_dir/44398EDD-22EB-4DED-BFAD-1BAD96E051FA.dmp
[task 2021-04-30T18:31:38.972Z] 18:31:38     INFO - PROCESS-CRASH | Main app process exited normally | application crashed [@ CoreFoundation + 0x9f1e]
[task 2021-04-30T18:31:38.973Z] 18:31:38     INFO - Crash dump filename: /var/folders/74/fjkgtzqn3619j60_57zsljm4000017/T/tmpwctb2809.mozrunner/minidumps/44398EDD-22EB-4DED-BFAD-1BAD96E051FA.dmp
[task 2021-04-30T18:31:38.973Z] 18:31:38     INFO - Operating system: Mac OS X
[task 2021-04-30T18:31:38.973Z] 18:31:38     INFO -                   10.14.5 18F132
[task 2021-04-30T18:31:38.973Z] 18:31:38     INFO - CPU: amd64
[task 2021-04-30T18:31:38.973Z] 18:31:38     INFO -      family 6 model 69 stepping 1
[task 2021-04-30T18:31:38.973Z] 18:31:38     INFO -      4 CPUs
[task 2021-04-30T18:31:38.973Z] 18:31:38     INFO - 
[task 2021-04-30T18:31:38.973Z] 18:31:38     INFO - GPU: UNKNOWN
[task 2021-04-30T18:31:38.973Z] 18:31:38     INFO - 
[task 2021-04-30T18:31:38.973Z] 18:31:38     INFO - Crash reason:  EXC_BAD_ACCESS / KERN_INVALID_ADDRESS
[task 2021-04-30T18:31:38.973Z] 18:31:38     INFO - Crash address: 0x0
[task 2021-04-30T18:31:38.973Z] 18:31:38     INFO - Process uptime: 750 seconds
[task 2021-04-30T18:31:38.974Z] 18:31:38     INFO - 
[task 2021-04-30T18:31:38.974Z] 18:31:38     INFO - Thread 3 (crashed)
[task 2021-04-30T18:31:38.974Z] 18:31:38     INFO -  0  CoreFoundation + 0x9f1e
[task 2021-04-30T18:31:38.974Z] 18:31:38     INFO -     rax = 0x56ef09d54abb0024   rdx = 0x0000000000000000
[task 2021-04-30T18:31:38.974Z] 18:31:38     INFO -     rcx = 0x0000000000000000   rbx = 0x0000000000000000
[task 2021-04-30T18:31:38.974Z] 18:31:38     INFO -     rsi = 0x0000000000000000   rdi = 0x0000000000000000
[task 2021-04-30T18:31:38.974Z] 18:31:38     INFO -     rbp = 0x000070000465d500   rsp = 0x000070000465d500
[task 2021-04-30T18:31:38.974Z] 18:31:38     INFO -      r8 = 0x0000000000000000    r9 = 0xffffffff00000000
[task 2021-04-30T18:31:38.974Z] 18:31:38     INFO -     r10 = 0x000000010f3af088   r11 = 0x0000000000000207
[task 2021-04-30T18:31:38.974Z] 18:31:38     INFO -     r12 = 0x0000000000000000   r13 = 0x0000000000000000
[task 2021-04-30T18:31:38.974Z] 18:31:38     INFO -     r14 = 0x0000000000000000   r15 = 0x0000000000000000
[task 2021-04-30T18:31:38.974Z] 18:31:38     INFO -     rip = 0x00007fff311aaf1e
[task 2021-04-30T18:31:38.975Z] 18:31:38     INFO -     Found by: given as instruction pointer in context
[task 2021-04-30T18:31:38.975Z] 18:31:38     INFO -  1  CoreFoundation + 0xfccc8
[task 2021-04-30T18:31:38.975Z] 18:31:38     INFO -     rbp = 0x000070000465dc10   rsp = 0x000070000465d510
[task 2021-04-30T18:31:38.975Z] 18:31:38     INFO -     rip = 0x00007fff3129dcc8
[task 2021-04-30T18:31:38.975Z] 18:31:38     INFO -     Found by: previous frame's frame pointer
[task 2021-04-30T18:31:38.975Z] 18:31:38     INFO -  2  libFontRegistry.dylib!TLocalFontRegistryImp::RegisterFont(__CFURL const*, __CFDictionary const*, unsigned int, unsigned int, __CFError**) const + 0x1de
[task 2021-04-30T18:31:38.975Z] 18:31:38     INFO -     rbp = 0x000070000465dd00   rsp = 0x000070000465dc20
[task 2021-04-30T18:31:38.975Z] 18:31:38     INFO -     rip = 0x00007fff2f87dffc
[task 2021-04-30T18:31:38.975Z] 18:31:38     INFO -     Found by: previous frame's frame pointer
[task 2021-04-30T18:31:38.975Z] 18:31:38     INFO -  3  libFontRegistry.dylib!TLocalFontRegistryImp::RegisterFonts(__CFArray const*, __CFDictionary const*, unsigned int, unsigned int, __CFArray const**, __CFArray const**) const + 0xbf
[task 2021-04-30T18:31:38.975Z] 18:31:38     INFO -     rbp = 0x000070000465dd70   rsp = 0x000070000465dd10
[task 2021-04-30T18:31:38.975Z] 18:31:38     INFO -     rip = 0x00007fff2f87ecd9
[task 2021-04-30T18:31:38.975Z] 18:31:38     INFO -     Found by: previous frame's frame pointer
[task 2021-04-30T18:31:38.975Z] 18:31:38     INFO -  4  libFontRegistry.dylib!XTRegisterFonts2 + 0x254
[task 2021-04-30T18:31:38.975Z] 18:31:38     INFO -     rbp = 0x000070000465de10   rsp = 0x000070000465dd80
[task 2021-04-30T18:31:38.976Z] 18:31:38     INFO -     rip = 0x00007fff2f8946a9
[task 2021-04-30T18:31:38.976Z] 18:31:38     INFO -     Found by: previous frame's frame pointer
[task 2021-04-30T18:31:38.976Z] 18:31:38     INFO -  5  CoreText!CTFontManagerRegisterFontsForURLs + 0x5f
[task 2021-04-30T18:31:38.976Z] 18:31:38     INFO -     rbp = 0x000070000465de70   rsp = 0x000070000465de20
[task 2021-04-30T18:31:38.976Z] 18:31:38     INFO -     rip = 0x00007fff32ec554b
[task 2021-04-30T18:31:38.976Z] 18:31:38     INFO -     Found by: previous frame's frame pointer
[task 2021-04-30T18:31:38.976Z] 18:31:38     INFO -  6  XUL!FontRegistrationCallback(void*) [gfxPlatformMac.cpp:b417d526e5fcdd4bfd59dc1b0599fd915b993969 : 153 + 0xc8]
[task 2021-04-30T18:31:38.976Z] 18:31:38     INFO -     rbp = 0x000070000465dec0   rsp = 0x000070000465de80
[task 2021-04-30T18:31:38.976Z] 18:31:38     INFO -     rip = 0x00000001067d0a04
[task 2021-04-30T18:31:38.976Z] 18:31:38     INFO -     Found by: previous frame's frame pointer
[task 2021-04-30T18:31:38.976Z] 18:31:38     INFO -  7  libnss3.dylib!_pt_root [ptthread.c:b417d526e5fcdd4bfd59dc1b0599fd915b993969 : 201 + 0x8]
[task 2021-04-30T18:31:38.977Z] 18:31:38     INFO -     rbp = 0x000070000465df10   rsp = 0x000070000465ded0
[task 2021-04-30T18:31:38.977Z] 18:31:38     INFO -     rip = 0x0000000105716511
[task 2021-04-30T18:31:38.977Z] 18:31:38     INFO -     Found by: previous frame's frame pointer
[task 2021-04-30T18:31:38.977Z] 18:31:38     INFO -  8  libsystem_pthread.dylib!_pthread_body + 0x7e
[task 2021-04-30T18:31:38.977Z] 18:31:38     INFO -     rbp = 0x000070000465df30   rsp = 0x000070000465df20
[task 2021-04-30T18:31:38.977Z] 18:31:38     INFO -     rip = 0x00007fff5d2fa2eb
[task 2021-04-30T18:31:38.977Z] 18:31:38     INFO -     Found by: previous frame's frame pointer
[task 2021-04-30T18:31:38.977Z] 18:31:38     INFO -  9  libsystem_pthread.dylib!_pthread_start + 0x42
[task 2021-04-30T18:31:38.977Z] 18:31:38     INFO -     rbp = 0x000070000465df50   rsp = 0x000070000465df40
[task 2021-04-30T18:31:38.977Z] 18:31:38     INFO -     rip = 0x00007fff5d2fd249
[task 2021-04-30T18:31:38.977Z] 18:31:38     INFO -     Found by: previous frame's frame pointer
[task 2021-04-30T18:31:38.977Z] 18:31:38     INFO - 10  libsystem_pthread.dylib!thread_start + 0xd
[task 2021-04-30T18:31:38.977Z] 18:31:38     INFO -     rbp = 0x000070000465df78   rsp = 0x000070000465df60
[task 2021-04-30T18:31:38.978Z] 18:31:38     INFO -     rip = 0x00007fff5d2f940d
[task 2021-04-30T18:31:38.978Z] 18:31:38     INFO -     Found by: previous frame's frame pointer
[task 2021-04-30T18:31:38.978Z] 18:31:38     INFO - 11  libnss3.dylib + 0x1593b0
[task 2021-04-30T18:31:38.978Z] 18:31:38     INFO -     rsp = 0x000070000465e090   rip = 0x00000001057163b0
[task 2021-04-30T18:31:38.978Z] 18:31:38     INFO -     Found by: stack scanning
[task 2021-04-30T18:31:38.978Z] 18:31:38     INFO - ```

During:

[task 2021-04-30T18:31:33.111Z] 18:31:33 INFO - TEST-START | Shutdown

After

[task 2021-04-30T18:31:32.695Z] 18:31:32 INFO - TEST-START | toolkit/components/antitracking/test/browser/browser_workerPropagation.js
[task 2021-04-30T18:31:32.826Z] 18:31:32 INFO - GECKO(1683) | JavaScript error: chrome://browser/content/places/browserPlacesViews.js, line 131: Error: No DOM node set for aPlacesNode.
[task 2021-04-30T18:31:32.826Z] 18:31:32 INFO - GECKO(1683) | node.type: 0. node.parent: [xpconnect wrapped nsINavHistoryResultNode]
[task 2021-04-30T18:31:32.975Z] 18:31:32 INFO - GECKO(1683) | JavaScript error: chrome://browser/content/places/browserPlacesViews.js, line 131: Error: No DOM node set for aPlacesNode.
[task 2021-04-30T18:31:32.976Z] 18:31:32 INFO - GECKO(1683) | node.type: 0. node.parent: [xpconnect wrapped nsINavHistoryResultNode]
[task 2021-04-30T18:31:33.073Z] 18:31:33 INFO - GECKO(1683) | MEMORY STAT | vsize 8256MB | residentFast 615MB | heapAllocated 163MB
[task 2021-04-30T18:31:33.074Z] 18:31:33 INFO - TEST-OK | toolkit/components/antitracking/test/browser/browser_workerPropagation.js | took 378ms

See Also: → 1708900

Jonathan, are you aware of changes causing the increase in these crashes (hit random tests)?

Component: Privacy: Anti-Tracking → Graphics: Text
Flags: needinfo?(jfkthame)

This is presumably related to bug 1707655. Let's see if we can identify any kind of pattern.....

Flags: needinfo?(jfkthame)

If I'm reading the details correctly, this is only happening on 10.14; are you aware of anything similar showing up on 10.15 or macOS 11 at all, or is this specific to the older OS version? If so, maybe we should just disable the threading optimization on that version as the OS seems flaky.

Flags: needinfo?(aryx.bugmail)

Based on this query, all 73 CI crashes in the last 4 weeks have been observed on macOS 10.14.

Flags: needinfo?(aryx.bugmail)

Looks like this is always a content-process crash, not the parent process. So maybe we can just disable the separate-thread task in content processes on pre-Catalina versions, and see how that goes.

Assignee: nobody → jfkthame
Status: NEW → ASSIGNED

This patch is a bit speculative, as there's no good reason for CTFontManagerRegisterFontsForURLs to crash just because it was called from a different thread, but I think all we can really do is land it and see how things go.

Regressed by: 1707655
No longer regressed by: 1708777
Duplicate of this bug: 1709011
See Also: → 1708777
See Also: → 1708791
Pushed by jkew@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8928abb7996b
On pre-10.15 macOS versions, don't do off-main-thread font registration in content processes. r=lsalzman
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch
You need to log in before you can comment on or make changes to this bug.