Closed Bug 1709001 Opened 1 year ago Closed 1 year ago

Switch to new Drag and Drop API for messagepane

Categories

(SeaMonkey :: MailNews: Message Display, task)

Tracking

(seamonkey2.53+ fixed, seamonkey2.57esr? affected)

RESOLVED FIXED
seamonkey 2.87
Tracking Status
seamonkey2.53 + fixed
seamonkey2.57esr ? affected

People

(Reporter: iannbugzilla, Assigned: iannbugzilla)

Details

(Whiteboard: SM2.53.8)

Attachments

(1 file)

Move away from using nsDragAndDrop to the new Drag and Drop API for messagepane, porting relevant parts of:

  • Bug 1226362 - Use HTML Drag and Drop API in Messenger

[Approval Request Comment]
Regression caused by (bug #): n/a
User impact if declined: none
Testing completed (on m-c, etc.): 2.53.8
Risk to taking this patch (and alternatives if risky): low
String changes made by this patch: none

Attachment #9219758 - Flags: review?(frgrahl)
Attachment #9219758 - Flags: approval-comm-release?
Attachment #9219758 - Flags: approval-comm-esr60?

Comment on attachment 9219758 [details] [diff] [review]
1709001-messagepane-DnD-2538.patch

LGTM

Attachment #9219758 - Flags: review?(frgrahl)
Attachment #9219758 - Flags: review+
Attachment #9219758 - Flags: approval-comm-release?
Attachment #9219758 - Flags: approval-comm-release+
Attachment #9219758 - Flags: approval-comm-esr60?
Attachment #9219758 - Flags: approval-comm-esr60+

https://hg.mozilla.org/comm-central/rev/7d4f985bcd22e36fceb773736ee8ff7743702c22
Switch to new Drag and Drop API for messagepane. r=frg

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey 2.87
You need to log in before you can comment on or make changes to this bug.