Last Comment Bug 17091 - Migrate history DB
: Migrate history DB
Status: RESOLVED WONTFIX
: helpwanted
Product: Core
Classification: Components
Component: Profile: Migration (show other bugs)
: Trunk
: All All
: P5 enhancement with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 60390 66755 233408 (view as bug list)
Depends on:
Blocks: 66954
  Show dependency treegraph
 
Reported: 1999-10-22 15:08 PDT by selmer (gone)
Modified: 2012-01-06 11:22 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description selmer (gone) 1999-10-22 15:08:02 PDT
The user's history file is not currently being migrated because it would need to
be changed from the Berkeley DB format to the current format.  As long as the
Berkeley DB tools are going to be shipped with Mozilla, it would be viable to
have a migration tool for the history file.

This is an enhancement that isn't likely to be worked on by Netscape employees.
Comment 1 (not reading, please use seth@sspitzer.org instead) 1999-10-30 12:49:59 PDT
HELP WANTED bugs go to nobody@mozilla.org
Comment 2 leger 2000-02-01 09:33:31 PST
Assigning all open "nobody@mozilla.org" bugs to "leger@netscape.com" to weed 
thru.
Comment 3 leger 2000-02-14 18:40:01 PST
Moving back to nobody@mozilla.org.  This is where the helpwanted will be 
assigned until someone picks them up.
Comment 4 R.K.Aa. 2000-12-16 19:05:51 PST
*** Bug 60390 has been marked as a duplicate of this bug. ***
Comment 5 Grace Bush 2002-02-05 08:51:29 PST
*** Bug 66755 has been marked as a duplicate of this bug. ***
Comment 6 David Aznar Reguero 2003-07-04 14:12:52 PDT
It seems that the change from Berkeley DB format to the current **** format
was needed because Berkeley DB was not available on some systems Mozilla tried
to support.

Now Berkeley DB seems to support all systems supported by Mozilla so we can
throw the current **** format (Mork) in preference to Berkeley DB. This way we
would also fix the critical bug 63292
Comment 7 R.K.Aa. 2004-02-08 03:04:03 PST
*** Bug 233408 has been marked as a duplicate of this bug. ***
Comment 8 Robert Emery 2004-02-08 06:28:26 PST
(In reply to comment #0)
> The user's history file is not currently being migrated because it would need to
> be changed from the Berkeley DB format to the current format.  As long as the
> Berkeley DB tools are going to be shipped with Mozilla, it would be viable to
> have a migration tool for the history file.
> 
> This is an enhancement that isn't likely to be worked on by Netscape employees.

If someone could tell me where I could learn about the Berkeley DB format and
the new Moz format, I would like to try and write a program to effect the
translation.
Comment 9 August Mayer 2005-05-27 03:10:59 PDT
Is this bug obsolete?
Comment 10 Gian-Carlo Pascutto [:gcp] 2012-01-06 11:22:08 PST
>Is this bug obsolete?

Yes.

Note You need to log in before you can comment on or make changes to this bug.