Closed Bug 1709301 Opened 1 month ago Closed 1 month ago

0.16% installer size (OSX) regression on Sat May 1 2021

Categories

(Firefox :: Messaging System, defect, P1)

Firefox 90
defect

Tracking

()

RESOLVED FIXED
90 Branch
Iteration:
90.2 - May 3 - May 16
Tracking Status
firefox-esr78 --- unaffected
firefox88 --- unaffected
firefox89 --- fixed
firefox90 --- fixed

People

(Reporter: alexandrui, Assigned: emcminn)

References

(Regression)

Details

(Keywords: perf-alert, regression)

Perfherder has detected a build_metrics performance regression from push 56373c5b3a010ebf99ece851a59a27bb2c2ed481. As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

Ratio Suite Test Platform Options Absolute values (old vs new)
0.16% installer size osx-cross 80,200,123.00 -> 80,329,994.92

Details of the alert can be found in the alert summary, including links to graphs and comparisons for each of the affected tests. Please follow our guide to handling regression bugs and let us know your plans within 3 business days, or the offending patch(es) will be backed out in accordance with our regression policy.

For more information on performance sheriffing please see our FAQ.

Flags: needinfo?(emcminn)

Set release status flags based on info from the regressing bug 1705825

This regression was expected due to the new media (background image and shapes) included in Proton new user onboarding. We're hoping to be able to further reduce the size of the images once .avif support lands (I think 90 is the goal for that), which should fix this regression.

Flags: needinfo?(emcminn)

One possible solution to reset the regression is by removing cfr pinned tab animation assets that are no longer used, see bug 1701091

This should be resolved by https://bugzilla.mozilla.org/show_bug.cgi?id=1708681, which will remove CFR assets and strings.

Iteration: --- → 90.2 - May 3 - May 16
Depends on: 1708681
Priority: -- → P1
Assignee: nobody → emcminn

Bug 1708681 has closed, which should resolve this. :)

Status: NEW → RESOLVED
Closed: 1 month ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch
You need to log in before you can comment on or make changes to this bug.