Closed Bug 1709338 Opened 5 months ago Closed 5 months ago

[Proton] Warning icons are not displayed in the Download Panel

Categories

(Firefox :: Downloads Panel, defect)

defect

Tracking

()

VERIFIED FIXED
90 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox88 --- unaffected
firefox89 --- verified
firefox90 --- verified

People

(Reporter: oana.botisan, Assigned: mconley)

References

(Blocks 3 open bugs)

Details

(Keywords: regression, Whiteboard: [proton-icons] [proton-uplift])

Attachments

(2 files)

Attached image image (3).png

Note
*

Affected versions

  • Firefox 89.0b7
  • Firefox 90.0a1

Affected platforms

  • Windows 10 x64
  • Ubuntu 18.04 x64
  • macOS 10.15

Steps to reproduce

  1. Go to http://testsafebrowsing.appspot.com/s/unknown.exe.
  2. Perform the download.
  3. Observe the download panel.

Expected result

  • The warning icon is displayed in the download list.

Actual result

  • The warning icon is not displayed in the download list.

Regression range

Additional notes

  • Please look at the attached image.
  • This issue is reproduving for all types of warnings.

Hi Mike! It seems that the patch from bug 1706777, caused this regression. Can you please take a look?

Has Regression Range: --- → yes
Has STR: --- → yes
Flags: needinfo?(mconley)

We need to supply both the width and height on the icon to make it appear. Also, as of
bug 1706777, we don't need the margin offset to vertically center the icon.

Assignee: nobody → mconley
Status: NEW → ASSIGNED
Whiteboard: [proton-icons]
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ffc96869b1e9
Make sure to show Download Panel warning icons. r=harry,desktop-theme-reviewers
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch
Flags: needinfo?(mconley)

Comment on attachment 9220133 [details]
Bug 1709338 - Make sure to show Download Panel warning icons. r?harry!

Beta/Release Uplift Approval Request

  • User impact if declined: Users that download files that are marked as unsafe by the SafeBrowsing list will appear without additional warning icons in the Download Panel
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): A CSS-only patch that operates by making sure that the icons have the appropriate height and width.
  • String changes made/needed: None.
Attachment #9220133 - Flags: approval-mozilla-beta?

Confirming here that we (UX and PM) want this uplifted for MR1 to Beta.

Whiteboard: [proton-icons] → [proton-icons] [proton-uplift]

Comment on attachment 9220133 [details]
Bug 1709338 - Make sure to show Download Panel warning icons. r?harry!

Needed for MR1, low risk approved for 89 beta 9, thanks.

Attachment #9220133 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

We can confirm that the issue is not reproducing anymore on latest Nightly 90.0a1, under macOS 10.15, Win 7 and Ubuntu 18.04 x64.

Flags: qe-verify+

This is also verified as fixed on Beta 89.0b9 under macOS 10.15, Win 10 and Ubuntu 18.04 x64.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.