Closed Bug 1709379 Opened 9 months ago Closed 8 months ago

Mute/Unmute tooltip is not displayed when video is played in PIP

Categories

(Firefox :: Tabbed Browser, defect, P3)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
91 Branch
Tracking Status
firefox89 --- wontfix
firefox90 --- wontfix
firefox91 --- verified

People

(Reporter: sergiu.negritas, Assigned: enndeakin)

References

Details

(Whiteboard: [proton-tooltips])

Attachments

(2 files)

Attached image Pinned PIP favicon

Affected versions

  • 89.0b7
  • 90.0a1 (2021-05-04)

Affected platforms

  • Windows 10
  • MacOS 10.15
  • Ubuntu 20

Steps to reproduce

  1. Open Firefox.
  2. Open a video/audio website. (ex. youtube.com)
  3. Pin the video/audio website.
  4. From the pinned tab open Picture-in-Picture.
  5. Hover over the mute/unmute favicon.

Expected result

  • Mute/Unmute tooltip is displayed.

Actual Result

  • The mute/unmute tooltip is not displayed and instead the title of the tab is shown.

Additional notes

  • I have attached a screenshot for better understanding of this issue.
  • In 88.0 the mute/unmute tooltip is not displayed at all (pinned tab or unpinned tab).
Priority: -- → P3
Severity: -- → S3
Assignee: nobody → enndeakin
Status: NEW → ASSIGNED
Pushed by neil@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d8c5d9c5149f
don't special case picture in picture mode in tooltips as the button is still a mute button, r=mconley
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch

Is this worth uplifting to 90 beta?

Flags: needinfo?(enndeakin)

Hello I have managed to reproduce the issue on Windows 10 with Firefox 90.0a1 (2021-05-04), I can confirm that the issue is fixed with Firefox 91.0a1 (2021-06-02) on all 0S's.
Leaving the resolution of this issue as resolved in case it will be uplifted to beta.

Thank you!

Ping timeout.

Flags: needinfo?(enndeakin)

As per last comment from Julien I will update this issue as VERIFIED->FIXED.

Thank you and have a nice day!

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.