Ability to set tabgroups as homepages

VERIFIED FIXED in Phoenix0.5

Status

()

Firefox
General
P1
enhancement
VERIFIED FIXED
15 years ago
15 years ago

People

(Reporter: Dennis Ouellette, Assigned: Blake Ross)

Tracking

unspecified
Phoenix0.5
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
I think a great feature would be the ability to lock-down the user-defined tabs.
Most if not all browsers give the user the ability to have a start-up page. Why
not use this same idea for the tabs? So if a user has let's say 5 tabs with
his/her favorite sites, the next time that user fires up Phoenix, all the tabs
would load with their favorite sites. This would be a real time-saver. In
effect, you would be giving the user a user-defined portal using the tab function.

Thanks

Dennis

Comment 1

15 years ago
Is this a request for bookmark groups (a bookmark that opens several tabs) as
startpage?
(Reporter)

Comment 2

15 years ago
No, but that is not a bad idea either. If I understand you correctly, you 
would select a "folder" from the "bookmark" menu and what ever happened to be 
in that folder, tabs would be created for each URL in that folder? That would 
be great also.

What I mean is that if you add tabs to Phoenix e.g. 5 tabs, each with 
different URL's, I could "save" the tab setup I just created so that the next 
time I launch Phoenix, the "saved" tab configuration would load as well as the 
same URL's that I assigned to those tabs on startup. 

Dennis

Comment 3

15 years ago
Sounds right to be. This feature would be useful.

Comment 4

15 years ago
so this is really just "when Phoenix starts up display the last page(s) visited"
where it could be a single page or several in tabs? 

You can already bookmark a group of tabs. Open several tabs and do Bookmarks|Add
to Bookmarks.  Then check the box that says "bookmark this group of tabs". Now
you have a bookmark that can load all of those tabs. You can edit this "bookmark
group" like it was a folder of bookmarks in the Bookmarks Manager, adding or
removing items. 

What you can't yet do is set this bookmark group as the startup page (like you
could a normal URL). 
You also can't say "start up with the last page(s) visited in the previous
session".  

Comment 5

15 years ago
->bookmarks.

this is either "start up with last page(s) visited" or "start up with bookmark
group".  I can't tell which.
Assignee: blaker → chanial
Component: General → Bookmarks
(Reporter)

Comment 6

15 years ago
Asa,

Thank you for clarifying the bookmark concept. I really like that you can load 
a bunch of tabs and save that as a bookmark. That is a really cool feature.

Personally, I think starting up with a "bookmark" group makes sense. What do 
you think?

Dennis

Comment 7

15 years ago
I think that the current plan is to eithe be able to specify a bookmark group or
a comma-separated list of urls in the preference for startpage. Sending to
preferences for now. 
Assignee: chanial → blaker
Status: UNCONFIRMED → NEW
Component: Bookmarks → Preferences
Ever confirmed: true
(Reporter)

Comment 8

15 years ago
Both ideas sound good to me. This will really make Phoenix a powerful user-
defined portal creator. That knocks the socks off of IE ;-)

Dennis

Comment 9

15 years ago
*** Bug 172976 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
I don't think this is talking about "start up with last page(s) visited". 
Dennis wants to have a fixed set of start pages.  If he starts with his five
favorite sites and then clicks through several links under each and then closes
the browser, he doesn't want all those extra pages to open the next time he
starts Phoenix...  just the original five and always the original five.

So, I think being able to have a bookmark group as a "Start Page" is the better
solution to the problem.
(Reporter)

Comment 11

15 years ago
> So, I think being able to have a bookmark group as a "Start Page" is the 
better solution to the problem.

I agree if that means when you launch Phoenix, everything that is in your 
bookmark group that you set as a "Start Page" opens as tabs. That would rock.

Dennis
(Assignee)

Comment 12

15 years ago
-> hyatt
Assignee: blaker → hyatt
Component: Preferences → General
Priority: -- → P1
Summary: Ability to lock-down tabs → Ability to set tabgroups as homepages
Target Milestone: --- → Phoenix0.5
(Assignee)

Comment 13

15 years ago
-> me; I have a fix for this but my internet connection is down at home.
Assignee: hyatt → blaker
(Assignee)

Comment 14

15 years ago
Fixed.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 15

15 years ago
VERIFIED in today's nightly.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.