Closed Bug 1709587 Opened 3 months ago Closed 2 months ago

Edit bookmark panel's save button outline focus should be more noticeable

Categories

(Firefox :: Bookmarks & History, defect, P2)

defect

Tracking

()

VERIFIED FIXED
91 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox88 --- unaffected
firefox89 --- wontfix
firefox90 --- verified
firefox91 --- verified

People

(Reporter: clara.guerrero, Assigned: bigiri)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [proton-door-hangers] [priority:2b])

Attachments

(6 files)

Attached video border.webm

Affected versions
latest Nightly 90.0a1 (2021-05-05) (64-bit)
Beta 89.0b8 (64-bit)

Preconditions
Set the following prefs in about:config

browser.proton.enabled = true
prompts.windowPromptSubDialog = true
prompts.contentPromptSubDialog = true
browser.proton.modals.enabled = true

Affected platforms
Windows 10 x64
macOS 10.15
Ubuntu 18.04 x64

Steps to reproduce

  1. Launch Firefox.
  2. Click on star icon to open add bookmark panel (or if a website is already bookmarked, to open the edit bookmark panel)
  3. Press tab key for outline focus to be triggered, and reach the save button.

Expected result
Save button outline focus should be more noticeable

Actual result
The outline is not noticeable.

Suggested Severity
S3, since this won't affect the end users.

Regression range
Not a regression.

Additional notes
Please observe the attached screenshot.

Has Regression Range: --- → no
Has STR: --- → yes
Severity: -- → S3
Whiteboard: [proton-door-hangers]

I believe this is due to lack of padding around the button before the focus ring, and it sharing the primary color.

Priority: -- → P2
Whiteboard: [proton-door-hangers] → [proton-door-hangers] [priority:2b]

This is also reproducible in update notification panel.
Best regards,
Clara

Assignee: nobody → bigiri
Status: NEW → ASSIGNED

Changed outline offset on bookmark panel save button to match spec.

Attachment #9226909 - Attachment description: Bug 1709587 - Edit Bookmark panel save button outline r=#desktop-theme-reviewers → Bug 1709587 - Edit Bookmark panel save button outline r=dao,#desktop-theme-reviewers
Pushed by bigiri@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/37163e0fa3f0
Edit Bookmark panel save button outline r=desktop-theme-reviewers,dao
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch

Is this worth uplifting to beta 90?

Flags: needinfo?(bigiri)

Approved for uplift.

Comment on attachment 9226909 [details]
Bug 1709587 - Edit Bookmark panel save button outline r=dao,#desktop-theme-reviewers

Beta/Release Uplift Approval Request

  • User impact if declined: Bookmark panel save button appearance will not match Proton spec.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: - Edit a bookmark by clicking on the Star icon in the URL bar.
  • Click in the name field.
  • Use tab to navigate to the Save button and the Remove bookmark button. (In OSX tabbing to buttons may need to be enabled in the OS under System Preferences > Keyboard > Shortcuts > "Use keyboard navigation to move focus between controls")
  • Note that the outline that appears on the Remove bookmark button and the Save button, and has the proper padding to make that outline visible.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Single line CSS change reflecting CSS that is used elsewhere for the same purpose.
  • String changes made/needed:
Flags: needinfo?(bigiri)
Attachment #9226909 - Flags: approval-mozilla-beta?
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Comment on attachment 9226909 [details]
Bug 1709587 - Edit Bookmark panel save button outline r=dao,#desktop-theme-reviewers

approved for 90.0b9

Attachment #9226909 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Attached video border.webm

This issue was verified in nightly 91.0a1 (2021-06-16) (64-bit). Updating flag accordingly.
Waiting to verify in beta.

Best,
Clara

Attached image beta.jpg

This issue was also fixed in beta 90.0b10 (64-bit), updating flag to verified as well.

Best,
Clara

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.