Closed Bug 1709687 Opened 1 month ago Closed 25 days ago

NotFoundError: Could not open the file webext.sc.lz4

Categories

(Toolkit :: Add-ons Manager, task, P2)

Firefox 88
task

Tracking

()

RESOLVED FIXED
90 Branch
Tracking Status
firefox90 --- fixed

People

(Reporter: kernp25, Assigned: barret)

References

(Regression)

Details

Attachments

(2 files)

Attached image firefox_bkLEqfsceI.png

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:88.0) Gecko/20100101 Firefox/88.0

Steps to reproduce:

Start Firefox Nightly (90.0a1 (2021-05-05) (64-Bit)).

Actual results:

In the browser console there is this error:
NotFoundError: Could not open the file at C:\Users....\AppData\Local\Mozilla\Firefox\Profiles\rlshia6o.default-nightly\startupCache\webext.sc.lz4

Is it logged only when the profile is new or on every run?

The startCache will not exist yet during the first run on a new profile and so it is expected that that file does not exist.
(e.g. if that is the case, the type of this issue could be changed to task or enhancement, because we may double-check if we can omit the log when Firefox is running on a newly created profile or turn it into a warning, but if it happens on every run there we should investigate more into what is going on).

Flags: needinfo?(lgreco) → needinfo?(kernp25)

The Bugbug bot thinks this bug should belong to the 'Toolkit::Startup and Profile System' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Startup and Profile System
Product: Firefox → Toolkit

(In reply to Luca Greco [:rpl] [:luca] [:lgreco] from comment #2)

Is it logged only when the profile is new or on every run?

The error will show every time a update is installed or when i start with a new profile.

Flags: needinfo?(kernp25)
Component: Startup and Profile System → Add-ons Manager
Severity: -- → S4
Type: defect → task
Priority: -- → P2

Barret, could you look at this?

Flags: needinfo?(brennie)
Regressed by: 1649593
See Also: 1649593

note, it probably needs to be e instanceof DOMException

Assignee: nobody → brennie
Flags: needinfo?(brennie)
Pushed by brennie@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/aa19cd65a1a6
Correctly check exception type in ExtensionParent.jsm r=rpl
Status: UNCONFIRMED → RESOLVED
Closed: 25 days ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch
You need to log in before you can comment on or make changes to this bug.